Need Help:NoSql database for openwrt

I’ve added a database of mysql using mariadb. However, I’d prefer using NoSql like Mongodb. I could not find any package for installation. Anyone familiar with this, or if it is not applicable…let me know. I’ve been working on this for quite a while. If it is not compatible, I’d save my time from further investigation. Thanks in advance.

You got to know any NoSql like Mongodb for openwrt

Dears, I am facing core dump errors to start mongodb.service My development is going to run mongodb in arch linux within bananapi R3. Could you please advice somthings I gotta check? Many Thanks.

With this kind of errors, you may have more luck on Archlinux(Arm) forum.

When googling your problem, Maybe this?

Most packages in the AUR are meant for use with x86. Actually arm-only packages are being deleted.

So it may turn out that the build options in the PKGBUILD are not correct for aarch64.

From archwiki mongodb page:

Furuthermore, coredumpctl info reported a signal 4 (ILL) meaning that an illegal instruction execution was attempted. In other words, the computer did not have the instruction set to run this program, at least not locally.

Thanks you for your sharing. I was stucking with openssl version and dependencies conflicting. The issues were solved by your bpi-r3 nosfp arch image

may i ask you some issues, it’s not related to mongodb,

your bpi-r3 nosfp arch image fixed a lot of my technical problems. Thanks.

But now, the PWM fan is not working after bootup arch linux. may I know the patch or how can I configure to work the fan. Thanks.

I haven’t done anything about fan pwm yet myself. It may be so that the temperature that the fan is activated is higher then before. There are quite a few threads here on the forum about fan pwm, so you may find some more info there.

If it turns out the kernel needs a patch, I’ll be happy to add it to the archlinuarm prebuild version. The kernel you are using is based on linux-rolling-stable, with a few patches, and follows the latest version there.

Which kernel do you have and can you readout the temperature via sysfs?

My fix was backported yesterday and i guess this is missing in your tree.


The patch is not part of linux-rolling-stable yet, so I’ve added it to my bpir-rolling-stable branch.

@genius1 You can

pacman -Syu

And the linux will be updated with the patch


After updated repo, I found the changes in sysfs temperature from -47000 to 41422.

The fan seems to be run when it reach 40’ C. Is that right?


the dtb files are updated after pacman -Syu.

The fan is not spinning yet.

This is normal, the overlays are stored as readable .dts files and merged into 1 .dtb file. The bootloader does not need to be able to use overlays. (technical details)

What is more interesting for you is the new /boot/Image file, where the new patch changed the code.

1 Like

I guess it will be 60 degrees:

Thanks for your prompt response.

My node js application server is running on your arch linux with SD Card image.

But I tried to flash the mmc image to emmc. (my bad technical issue).

Although I follow the ways you provided here in github.

Its not working for me. /tmp directory is automatically removed every data inside it when bootup. It only store runtime data.

Can you provide the way to flash emmc for your arch image. image

yes, i increased the temp while fixing the thermal trips:

1 Like

Then you pressed ‘shift e’ too late. The idea is to interrupt the boot process at an early stage (initramdisk).

Only when fully booted, mount is set over the /tmp folder and indeed you cannot see the file. You will see it when running from initramdisk.


This is kinda offtopic, better continue here:

1 Like

Ah, I see, I gonna test today again. Thanks Very much.

Finally, I got emmc boot with arch linux. Thanks for your valued times. I appreciated.