Installing Google Play Services on Banana Pi M3 Android L

Grand merci. Ça marche Merci

Ive done something wrong, when I run the adb devices command, its says List of devices attached, then blank, ideas?

Under device managers, can you see your device listed as Android ADB? If yes, then the phenoix burn tool should also see your device. And if that happens, you should have a device when you run the devices command.

Wasnt there at all, plugged in a 2nd usb cable and it appears as an unknown device

Try to install the drivers then http://forum.xda-developers.com/showthread.php?t=2588979. Also make sure you are plugging in the OTG port to the computer, and the power port in a 2A adapter. The OTG port is on the same side s the SATA/HDMI ports.

I had already done that, But tried again with 1.4.2 and 1.3, windows still says unknown device

HI
first, you can download from here: https://www.wandoujia.com/### and then try again.

1 Like

I am writing through translator apologize for English. I should windose 7 (64) How do I set GAPS and the driver device

  1. Place the device on android
  2. Connect the 5V-2a and connected to a device and OTG to the computer USB
  3. When you turn on the device, press and hold the service BOOT button next to the LAN, press the power button to keep the device lights up red sve.
  4. The dispatcher device is an unknown device,
  5. set the adb-setup-1.4.3.ehe pressing everywhere - Y - Enter-wait for 15 seconds
  6. Reboot the device with two buttons in the Boot Mode
  7. Install the driver to manually select the unknown device Android device further Android adb interface
  8. Reboot your device into normal mode, now we see the Android ADB interface
  9. Copy System Works folder on the C: \ system
  10. Load CMD as administrator

cd c: \ adb adb devices (the device has to be seen how numbers 000000000000) adb connect adb remount adb push system / system adb reboot

@alexandr , а ты чего спросить то хотел? я вопроса не вижу.

1 Like

Странно вроде ни чего не спрашивал )) Может чего нажал не то на форуме сори ))) Вопросы были пока не разобрался как в банане прошить GAPS/

I also have the problem with the command ‘adb connect’ with M3, finally i found a solution and tested under windows and ubuntu,both work.

  1. Connect M3 with USB cable to PC computer/Linux computer
  2. ‘adb usb’ You will see a window pop up show android devices.
  3. ‘adb kill-server’
  4. ‘adb start-server’
  5. ‘adb tcpip 5555’
  6. ‘adb connect 192.168.xxx.xxx’ 192.168.xxx.xxx is the android IP address
  7. ‘adb devices’ You will see there are two devices connected, then you can disconnect the usb cable and push the ‘system’ folder contents to M3 eMMC.
  8. 'adb push C:/users/blabla/system/ /system //for sure replace your system folder path…
  9. ‘adb reboot’

If still doesn’t work, can try to input the ‘adb usb’ command after ‘adb start-server’. Sorry for my poor English.

1 Like

Hello! I’m selling incent Android installs for apps on Google Play. Only real devices.

In the presence of GEO: RU; EU; USA Volumes are now on the order of 3k / daily and are constantly increasing. The cost of traffic from 0.05 dollars / installation.

Help to bring the application to the TOP and promote search keywords in the search results, For details, write :

Jabber: [email protected] Email: [email protected] skype: live:398230e1d9cdade5 Сайт : mobiliker.com

After I’ve tried everything from here, I tell you how it really works: Download this archive with Chrome: (Firefox makes problems) Https://mega.nz/#!k08h0IZI!SI2cRwELlKdC73YWIiF0oz2NmUafMJB0PZhLOuxdt9Y

Unpack the archive and copy it with the PC on your BPI Then you routed your BPI with Kingoroot (PC version) This is done download the Rootexplorer. Copies the contents of the archive to the system folder (Attention You must enter the folder Write permissions in the Rootexplorer above the folder) If this is done, do not forget to re-mark the folder as read-only or it will not work. Restarts the BPI and what do you see: Now you have your playstore synonymous - I’m sorry for my bad English