I want to flash the image with SD card, but when I choose the way as shown below, I have a problem

I want to flash the image with SD card, but when I choose the way as shown below, 1660535494897 Ubuntu16.04 I have a problem b1e7a69b20f576e182fc4b822faf8c8 it’s stuck here

May I ask which image did you burn?

I’ve posted debian and ubuntu images here for r2pro,but you have to erase emmc to use them as they use mainline uboot

I am using Ubuntu16.04mate

Meaning if I want to boot from emmc and use it, I can’t choose Ubuntu? Do you have the full image in use here?:joy:

My images were for sdmmc,have not tried them on emmc.i guess there are some changes (root param and partition value in uboot and fstab in linux) needed.

But you can try booting it from sdcard. At least they are actual versions…u16.04 is end of live

use a normal Armbian system (you can choose Ubuntu or Debian), you don’t need to erase anything in eMMC. After starting and checking how it works from an SD card, you can easily install the system you need in eMMC and at the same time get the opportunity to run any systems from an SD card or directly from USB media (i.e. you can install Ubuntu on eMMC and, if necessary, run Debian from USB\SD). If you wish, you can build your own version of Armbian directly on R2 pro with your own set of packages and settings.

https://forum.banana-pi.org/t/armbian-and-libreelec-for-bpi-r2-pro-rk3568/13308/19

Same issue. Received my board today, I don’t have usb to usb cable. So I followed guide from wiki, flashed ubuntu/debian on sd (samsung 64gb). But nothing work. Ubuntu just pop up with “linux system recovery” and nothing happens. Debian can’t recognize keyboard. Armbian - no video output (hdmi). Images from @frank-w no video too. Literally don’t understand how to make it work.

Yes,my images have no hdmi userspace (x-server) installed, as it is designed as router.imho fb console should work,but not tested.

Are you sure the image from sd is booted? My board had emmc with data which prevents bootup from sd without pressing maskrom button.

Thanks for reply. I think no, tried few official images but no luck on Debian/Ubuntu. Only linux recovery console. Official images flashed right in wiki page with Rockchip tool, images which can boot from sd via balena etcher, flashed Altlinux (also board connected to my roater via cable), but nothing happened, seems like no hdmi too, but I think if system booted the new client should pop in router dashboard.

Seems I can’t make it work without usb cable.

Ok I read the thread about broken bootchain. So as I understand, I need to flash sdcard update (i.e. ubuntu), then insert sd, hold maskrom button and then power on. Tried right now but again in linux system recovery. Raspbian can boot, finally. Is it possible to erase emmc now?

After one hour of “sudo dd if=/dev/zero of=/dev/mmcblk1” I see “linux system recovery” again lol. Also I can’t login to created user in armbian after reboot. Wtf with this board, just wtf.

It looks like you have problem with eMMC. Try to burn an Armbian image to an SD card and USB drive, connect BOTH media (SD card and USB flash drive simultaneously to the device) and turn on the power. If the system starts normally, then you have problem with the eMMC\SD card reader or SD card. It is important that if you have written any old system to the SD card (for example, the official image for BPIR2pro), you need to completely erase the SD card with the DD command and only after that write the Armbian image.

Thanks. Did not try your method, will try slightly later. Got A-A cable today, flashed via maskrom/loader few images. Ubuntu/Debian from from forum working, images from google drive not working (bpi logo stuck), openwrt not working too. At this moment I don’t have a lot of time it’s too much hustle for me with this board. Will back later.

Do you have any output via serial? (microusb port)

Hi, thanks. Finally flashed ubuntu image from wiki. Working fine except two things:

Summary

[email protected]:~# apt upgrade Reading package lists… Done Building dependency tree… Done Reading state information… Done Calculating upgrade… Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 1 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Setting up flash-kernel (3.104ubuntu12) … flash-kernel: deferring update (trigger activated) Processing triggers for initramfs-tools (0.140ubuntu13) … Processing triggers for flash-kernel (3.104ubuntu12) … Can’t find /boot/vmlinuz- (see /tmp/flash-kernel-no-kernel-error.log) dpkg: error processing package flash-kernel (–configure): installed flash-kernel package post-installation script subprocess returned error exit status 1 Errors were encountered while processing: flash-kernel E: Sub-process /usr/bin/dpkg returned an error code (1)

And iptables not working: iptables/1.8.7 Failed to initialize nft: Protocol not supported

Don’t need to upgrade system?