How to Install GApps to Android 6 on eMMC from Ubuntu


  1. you must have already done the “How to Flash Android to eMMC from Ubuntu” How to Flash Android to eMMC from Ubuntu
  2. you must be able to boot into Android 6 on your BPi-M64 already.

Download: I have prepared a set of open gapps easy for you to push to the /system folder


  1. make sure your BPi-M64 is power connected and also USB OTG connected to your PC.

  2. double check if your usb is connected by typing:

      adb devices
  3. if it shows one long unique id number under the List of devices means you are connected and ready to go.

  4. type the following:

      adb root
      adb remount
      adb shell "rm -rf system/priv-app/PackageInstaller"
  5. unzip the gapps.tar.gz file you have just downloaded.

  6. cd gapps

  7. inside gapps folder, you should see only 1 system folder, then type:

      adb push system /
      adb shell "pm grant android.permission.ACCESS_COARSE_LOCATION"
      adb shell "pm grant android.permission.ACCESS_FINE_LOCATION"
      adb shell "pm grant android.permission.READ_PHONE_STATE"
      adb shell "pm grant android.permission.READ_CONTACTS"
      adb reboot

after reboot, ignore any “unfortunately … has stopped” message if got any… and please don’t rush to open the apps yet, else it will cache the error and make things more complicated.

Fix Errors via Settings:

  1. go to Settings->Apps

  2. go into all the newly installed google apps, and go into the permissions, allow all of it that it suggest you to enable.

  3. double check if any google apps that you miss adding the permissions.

  4. reboot again by typing:

      adb reboot
  5. done!

if you didn’t listen and rushed to open apps before fixing the permissions, you will have to go to Settings->Apps->top right corner menu choose “Reset app preferences”, then reboot, and then go fix the permissions first, then reboot, then it should be ok.


Support Android GMS Service. Good job !

I cannot get it to work. it crashes at the setup wizard. ive tried everything. can you update the guide?

HI: We will update new android as soon as possible.

The android image works great! I just can’t get Gapps installed

don’t skip these

adb root adb remount adb shell “rm -rf system/priv-app/PackageInstaller”

first 2 lines is to make sure you have root access at root folder, else it will be readonly and can’t push. 3rd line is to make sure you are not using the old setup wizard by removing it… because you will push in a new installer that come with the system folder i prepared.

Hi Man,

Im trying to follow up your instruction about how to install Google play store on android, but the Gapps that you shared on Baidu doesnt seem like that it is working!!

I tried with multiple different download managers, but all failed. Could you please share the zip file on another provider, ie Gdrive or Mega??

Thanks :slight_smile:

1 Like

Thanks mate, I have installed the google play services successfully with your guide and it works absolutely fine.

Only one thing that i noticed is that the output audio has some noise in the background.

I have a hdmi cable running between the BPI and my TV. For example when i play a movie in Kodi, the audio is good for a few seconds and then the noise comes in the background and goes away again and so forth. :frowning:

Is there any way that i can fix this issue??

I have tried with multiple different HDMI cables and had the same results. Thanks

It could be the rusty on cable’s male connector or female port at tv… it could be the power to pi is not stable… sometime its just because the “gains” are not matched for 2 different connected device which can be solved by adjusting it with a good equalizer software.

Another problem would be both 3.5mm audio jack and hdmi audio is enabled. You will have to disable either one.

The HDMI connection is secure and clean on both side. About the headphone jack, any suggestions on how to disable it in android?

Other thing that I noticed is that the audio is completely fine when I play music on Spotify. The noise only starts when I play a video in YouTube or Kodi. Thanks

Can try look into SoundAbout app… not sure how well it work. Or u can look into developing ur own app to force select. I will try built a simple app to force select later when i got time.

sure, yea i might give it a go. by the way i tried to root this image, but apparently the boot-loader is locked and i cant root the android. any idea about that?

Sorry to ask you a lot of questions tho :slight_smile:

busybox is already included in this image… if you want to modify the bootanimation or boot logo or put in root app… can just do adb root then adb remount

Btw i have just tested soundabout… its good to go… it also remove the problem of having a poping jeezzz sound every few seconds… force only 1 audio output is the way to go.

Thanks a lot man, I’ll let you know how i go. :slight_smile:

i don’t know what i am missing

[email protected]:~/gapps$ adb push system / push: system/framework/ -> /framework/ failed to copy ‘system/framework/’ to ‘/framework/’: Read-only file system [email protected]:~/gapps$

Hi all! anyone can help me? i try to install gapps but in the middle of process when i try to give the permision the i got an error on adb cosole “No device connected” now i try to flash my m64 with phoenixsuit but cat flash a new image

Hi @Chong_Thien_Pow,

I have tried your exact approach to install Gapps on Banana Pi M64 with Android 8.1.

I literally copied your gapps folder and replaced apks relevant for Android 8.1.

It installed as well but it gives me error when trying to sign in in google play store “failed to connect google service framework”

I need your help on this if you could guide me to achieve Gapps installation on Android 8.1