How to boot into uboot?

This is supposed to a simple task to boot into uboot. However, I can find a way to do it. The uboot button on the board doesn’t seem to do anything at all.

what is the Problem?

uboot is loaded everytime if your image is working correctly…you can only access it via debug-uart…after 3 seconds it boots the default entry (loading kernel-param in uenv.txt)

I have uart and I can see the debug message during the boot process on minicom.

I want to boot into uboot, be able to access the uboot prompt and start execute the uboot commands, like the following uboot command

BPI-EMMC> printenv

How to get the uboot prompt?

if you watch early boot-process in debuguart you’ll come to the bootmenu which is uboot. Here the 3rd entry is selected and will be loaded after 3 seconds if you do not change it. In this menu you can select uboot-console to get the prompt you want

Thanks for your reply, Frank.

I actually saw the bootmenu early on. However, I can’t use the keyboard to change the menu selection through minicom. For some reason, the keyboard doesn’t work. I’m not sure what is the problem.

Keyboard from client where minicom is running,not keyboard connected to bpir2

Yes. It’s the keyboard where minicom runs. The keys are not working. Can’t change the menu.

I have been using minicom for a long time. Never experience such problem.

Uboot uses imho only arrow up/down keys.

Have you checked your wiring (all 3 pins have to be connected) and settings (speed,flowcontrol)?

Can you login into system after it prints prompt in minicom?

@frank-w what does the uBoot button do ?

@xjianz, if your serial is wired correctly(TX->RX,RX->TX, GND->GND), it’s also possible that you have a cheap knockoff TTL->USB adapter. I have seen exactly the same problem with cheap knockoffs.

I use this one:

Verified to work under linux

I don’t know what the button do…

The switch introduced with 1.2 (above sd-slot) should choose boot-device if sd and emmc are bootable. Normally sd is used first an if none present or not bootable emmc is tried.

@xjianz which chip has your uart-adapter? I had problems with profilic-chipset…now using cp2102

My cable has profilic-chipset. I have just tried another cable (still profilic-chopset), and have the same problem.

Not sure if I can find another cable with different chipset.

However, I have been using profilic-chipset with other devices and have no such problem. Weired

Hi, felix. If You can’t find proper USB2TTL - You can try arduino leonardo(or as in my case arduino pro micro) I’m using next sketch. And it’s ok with my R2.

The only inconvenience for me - need to use 5v-3.3v level shifter in case of 3.3v I/O.

Just search for cp2102 on ebay…

Tried two more usb-to-TTL cables with different chipset. CH340G chipset failed, same problem that keyboard does not work. A FTDI FT232 cable works fine. I can final get keyboard working in minicom.

Is this a hardware incompatibility problem? Or is it can be fixed by software? Uboot?

profilic-chipset - failed
ch340g - failed
FTDI - ok
cp2102 - ok

1 Like

on r2-side it is no driver-issue, because you need driver for usb2uart on client (where minicom runs). maybe it can be fixed by setting console settings of the ttyusbx-device, but i think it is a hardware-issue

good to hear, that you can work now :wink: thank you for summarization

The problem is the manufacturer, linux developers don’t know about all sorts of secret hardware bugs errata that those knockoffs* have so they don’t know how to exactly bring them back to life when they croak.

I use FTDI I posted for you earlier and it has worked really well because it seems really well documented:

PS: I’m in no way associated with FTDI

*I am talking about shady manufacturers making knock off chips, cutting all sorts of corners so they can undercut the price and labeling it as if part was made by genuine part manufacturer.

Thanks for all the help :slight_smile:

I was almost buying the cp2102 online as suggested. Luckly, I found my spare usb-to-ttl cables and one of them is FTDI.

I would hope this hardware fault or incompatiblity issue can be mentioned on the wiki and gitbook.

For profilic-problems it is mentioned in my wiki…i will add the others

An option which may be of use to some - using an arduino as a serial-usb converter. Note - Although I did this without a level shifter and nothing blew up, I cannot guarantee this will be safe in all cases

To do this, connect the RESET pin of the arduino to GND (keeps the arduino in reset mode) Connect GND of the banana pi R2 to GND of the arduino Connect TX of the banana pi R2 to TX of the arduino Connect RX of the banana pi R2 to RX of the arduino. (Ordinarily I would connect Rx of system 1 to Tx of system 2, and vice versa, but ehh…) Connect the arduino to your computer via usb. Tested on the arduino Uno, 115200. No sketch required. Just Putty.