How to boot BPiCM4 from sd card while os installed in emmc

Due to the issue How to make CM4 work with Waveshare CM4-IO-BASE-B , I can only access BPi through ethernet or wifi, by mistake I’ve wrongly configured the network of os in EMMC. Now Bpi always boots the os of Emmc. how to make it boot from scard. I tried to erase Emmc with usb burning tool on windows. but the start button is always greyed out though it says HUB3-2 is connected.

I guess may be you could check the boot.ini the eMMC. There could something like root=UUID=some_uuid. The UUID should be the UUID of the eMMC where the OS is booted from. Change it to the UUID of your SD.

Or you could just erase the eMMC using dd.

I tried:

lubuntu@lubuntu:~/workspace/aml-flash-tool$ ./  --img=/home/lubuntu/zero.img --parts=all --wipe
Unpacking image [KO]

and it still boots from emmc.

lubuntu@lubuntu:~/workspace/aml-flash-tool/tools/linux-x86$ ./update bulkcmd "disk_initial 1"
AmlUsbBulkCmd[disk_initial 1]
AM_REQ_BULK_CMD_Handler ret=-110,blkcmd=disk_initial 1 error_msg=error sending control message: Connection timed out
[AmlUsbRom]Err:rettemp = 0 buffer = [disk_initial 1]
ERR: AmlUsbBulkCmd failed!

how can I edit boot.ini of the eMMC?

You can boot from the linux in eMMC, right? If yes, it is in the /boot directory. If not, I think I have misunderstood you.

Yes, I can only boot from the Linux in eMMC but I’m unable to it via USB/Serial/Ethernet/WiFi