FYI: This $10 1000Base-T SFP Transceiver works with the BPi-R4

https://www.amazon.com/gp/product/B0CJCDDLDG/

“XZSNET 1000BASE-T SFP Transceiver, SFP to RJ45”

I just got it delivered and plugged it in. Linux detected it as it should and it auto-negotiated gigabit speeds with my Netgear (gigabit) switch. I’m able to pass traffic just fine and even scp’d a few things. No benchmarks yet though.

Shows up as eth1:

root@OpenWrt:/# ethtool eth1
Settings for eth1:
        Supported ports: [ FIBRE ]
        Supported link modes:   1000baseX/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  1000baseX/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  1000baseX/Full 
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: FIBRE
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

Not sure why it says, “FIBRE” but it works so… Whatever :smiley:

This is what dmesg says about it:

root@OpenWrt:/etc# dmesg | grep sfp
[    2.404444] sfp sfp@0: Host maximum power 3.0W
[    2.408907] sfp sfp@0: tx disable 1 -> 1
[    2.412998] sfp sfp@0: SM: enter empty:detached:down event dev_attach
[    2.419439] sfp sfp@0: SM: exit empty:down:down
[    2.424096] sfp sfp@1: Host maximum power 3.0W
[    2.428554] sfp sfp@1: tx disable 1 -> 1
[    2.432484] sfp sfp@1: SM: enter empty:detached:down event insert
[    2.438571] sfp sfp@1: SM: exit probe:detached:down
[    2.443573] sfp sfp@1: SM: enter probe:detached:down event dev_attach
[    2.450010] sfp sfp@1: SM: exit probe:down:down
[    2.759028] sfp sfp@1: SM: enter probe:down:down event timeout
[    2.775987] sfp sfp@1: module OEM              SFP-GE-T         rev A    sn C23Y32WS03000    dc 240109  
[    2.785462] sfp sfp@1: sfp: support mode 00,00000200,00006040
[    2.810055] sfp sfp@1: SM: exit present:down:down
[   15.411562] sfp sfp@1: SM: enter present:down:down event dev_up
[   15.417526] sfp sfp@1: tx disable 1 -> 0
[   15.421496] sfp sfp@1: SM: exit present:up:wait
[   15.489344] sfp sfp@0: SM: enter empty:down:down event dev_up
[   15.495093] sfp sfp@0: SM: exit empty:up:down
[   15.499642] sfp sfp@1: SM: enter present:up:wait event timeout
[   15.505511] sfp sfp@1: probing phy device through the [MDIO_I2C_NONE] protocol
[   15.512821] sfp sfp@1: SM: exit present:up:link_up

NOTE: This is with the version of OpenWRT that came with the BPi-R4. I haven’t updated it (yet).

I have no affiliation with this vendor or amazon or anything else like that. I just wanted to report what worked for me since I couldn’t find much in the way of a “compatibility chart” and few folks reported using SFP at all in this forum for non-fiber stuff. I plan to keep all the regular LAN ports as LAN ports and use SFP for the WAN and this transceiver makes that work. Nice and cheap too :smiley:

1 Like

I would suggest using a sfp with Marvell 88E1111 inside. The phy is detected and is fully supported

I got the Aocclink SFP 2.5G module (mikrotik) from aliexpress, works like a charm for only € 14. considerably more than the $10 you’re saying, but I think the 2.5G speed is definitely a + for these powerful routers

Also for 2.5g there are some with full phy support in openwrt, namely with rtl8221b inside. The one from luleey is one of them.

I tested this one https://www.aliexpress.com/item/1005005961638364.html

and it works fine but very hot, and I not sure how it will be during log used without active cooling