Failing to boot BPI r64


I received my banana Pi r64 yesterday. I hooked my USB to serial adapter up to the uart ports on board. However I’m struggling to boot the device.

Plugged in 12v 2amp power supply. Opened putty with the correction settings, (115200, 8n1 none, none)

I get a red flashing led that sounds like its beeping. However nothing shows in putty console. I’ve ordered another USB to serial adapter to check mine isn’t compatible.

I’ve tried booting with sd card with openwrt snapshot and also Ubuntu on but same result regardless.

I’ve seen other posts for r2 that say all three LEDs are on constantly, however I’m only getting flashing red Led on my r64. Is there a document that outlines Led behaviours, ie is flashing red an error code of some sort or is that normal behaviour.

My new serial to usb adapter should be arriving today so Ill retest with that later today.

i don’t know blinking red light. but imho you cannot compare r2 with r64 here

but you should see at least bootrom-code on serial regardless of sd/emmc-content or bootswitch-position

if you see nothing, you have a incompatible adapter, wrong settings (maybe wrong device) or incorrect wiring (TX of one side to RX of the other side + GND)

Thanks for the fast reply Frank,

Thats helpful. I’ve tried bootswitch in each position but no changes. What is the correct position for that?

Fingers crossed it is just my adapter not being compatible. Yes rx to tx was wired up correctly.

Bootswitch sets first bootdevice,if this cannot be booted r64/r2 tries the other. 0 is emmc and 1 is sdcard. So it should be in 1 position to try sdcard first then emmc.

Still no luck wit the new serial adapter. Tried putty on Windows and also minicom on Debian 9. Same result of a blank screen on both. Baud 115200, Data 8 Stop 1, Parity none, flow control none.

On the TTL UART 6 pin CP2102 module I’ve got RXD to TXD, TXD to RXD and finally GND to GND.

I’ve tried boot switch in both positions with no change. I’m using a 24w power supply, 12v 2amps. I’m looking for a another supply to test it with to make sure it’s not the power supply causing the issue, however that’s brand new bought specifically for this.

Seems to be a lost cause. I’ve tried pressing and holding each of the buttons I can but based on diagrams I can see online I wouldn’t expect those to do anything.

Does flashing red LED mean anything? None of the other LEDs have flashed or lit up. Is that normal, it doesn’t feel/sound normal but I’ve not been able to find a video or manual of what the LEDs should do on the R64 on boot.

Thanks again for the advice Frank, seems like it must have been damaged in postage if there’s nothing else you can think I should try?

R64 does not need any button pressed…it starts booting if power is supplied. Afair my r64 show only red led without blinking.

Thanks Frank,

I’ll try get my hands on a different power supply. If that’s not it then it must have been damaged in postage.

Thanks for your help

Hi Matt! You can try to check voltage settings on your adapter. Mine has 3.3V/5V jumper. It is working only in 5V position. At first I also had issues with connection and even fried old TTL adapter or it was so buggy. Try FT232 TTL, imho it is stable and reliable, ease to use. While boot red and blue are constantly up, without blinking.

Thanks for the reply, I think my original adapter was that exact one. Thanks for the advice with 5v, gave that a go but seems the board was damaged in delivery. I’ve sent it back and got another on order.