Error SP-flash tool

My board stopped responding when I tried to flash openWRT 18.06.1. I wanted to restore the firmware via SP_flash_tool, but got the error:error_sp_flash

I do not understand how this happened, but I rewritten the preloader and uboot. Now I have an uboot prompt like “MT7623>”

I tried to flash Openwrt through tftp, but when I restart, I see:

mmc0 is current device
mmc0 operation
dev_num = 0

MMC read: dev # 0, block # 2560, count 1 ... 1 blocks read: OK
[do_read_image_blks]Bad Magic Number = 0x27051956
mmc0 operation
serious check
Bad Data CRC
bootm flag=0, states=70f
## Booting kernel from Legacy Image at 84000000 ...
   Image Name:   ARM OpenWrt Linux-4.14.63
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4235490 Bytes = 4 MiB
   Load Address: 80008000
   Entry Point:  80008000
   Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!

How I can to flash latest uboot?

Hello,this tools is mainly used to burn android on R2, if you want to burn openwrt image on R2, I recommend you use ubuntu PC commands, please see here: