EMMC/SD Boot switch software override?

Is there a way to override the EMMC/SD boot selector switch? I assume it would be through the u-boot console. For example, if the switch is on the SD setting, can u-boot still boot from EMMC?

Uboot should be loaded from emmc if preloader was loaded from it…uboot is first position you can modify.

You can boot kernel from emmc with sd-uboot…just change first value in partition variable (0=emmc,1=sd) used in fatload.

1 Like

Hello, After install u-boot, my bpi-r2 ask me password, but password is not configured, I try all passwords and still ask me a password only in web interface. somebody can help me pls? Screenshot%20from%202021-12-11%2017-12-11

you need to tell us which image you are using…

Thank you for answer, do no matter image, it do it the same on any , this is my image https://downloads.openwrt.org/snapshots/targets/mediatek/mt7623/openwrt-mediatek-mt7623-bananapi_bpi-r2-sdcard.img.gz

and u-boot image https://downloads.openwrt.org/releases/21.02.1/targets/mediatek/mt7623/u-boot-mt7623n_bpir2/u-boot.bin

BusyBox v1.34.1 (2021-12-10 10:33:49 UTC) built-in shell (ash)


| |.-----.-----.-----.| | | |.----.| |_ | - || _ | -| || | | || || | |_____|| |||||___||| |____| || W I R E L E S S F R E E D O M

OpenWrt SNAPSHOT, r18302-ea49690ff4

=== WARNING! ===================================== There is no root password defined on this device! Use the “passwd” command to set up a new password in order to prevent unauthorized SSH logins.

How can I do a factory reset ?

do you get a prompt on serial console? so you can try setting password using passwd command like it is printed. but no idea about lucy…but it should be possible too if you have access via serial or ssh

I can Access by ssh, I change password but it always ask me login and password.

Ok, afaik ssh without pass is not possible…and openwrt uses no ext4 rootfs (squashfs or similar) and sometimes mtd which makes it hrd to chroot to it and run passwd outside running system. Maybe @dangowrt knows a way to set root password and make ssh login possible

Thank you for your help, I will try my self to find a solution, thank you again Frank

This doesn’t even look like OpenWrt’s UI…? Did you install a custom LuCI theme or maybe this is a different device or something still stuck in your browser cache?

As you got access via SSH you can run firstboot to reset everything to factory defaults. However, as there is no password set, you should also be able to access the web-ui by just submitting an empty password.

Thank you for your reply , I know is not necessary password to login. I can connect with ssh without password, I think the web isn’t complete, something loos.

I found it, if that help someone, this is the solution, the packages were incomplete,

opkg update

opkg install luci

opkg update

opkg install luci-ssl

/etc/init.d/uhttpd restart

Solved

1 Like