Does BPI-R3 support Routing/NAT Offloading?

Hello, Does the BPI-R3 support Routing/NAT Offloading ?

Network > Firewall > General settings > Routing/NAT Offloading Experimental feature.

Not fully compatible with QoS/SQM.

Software flow offloading - Software based offloading for routing/NAT

Hardware flow offloading - Requires hardware NAT support. .

I am using SQM with cake-autorate script

openwrt supports it, mainline-kernel have still a bug where one direction is not recognized in conntrack to be offloaded so no BND entries are created (so not working in mainline-linux)

1 Like


So, I should have these setting disabled, or enabled?

in openwrt? i’m not using it so i cannot guide you how to enable :wink:

sorry, the problem was with WED (wireless offloading)…normal NAT offload (ethernet-ports) works on mainline

1 Like

Thank you for the information.


I just turned BOTH of those setting OFF.

Rebooted, an now get an A on bufferbloat test in the FireFox browser.

NEVER got above a D before!

This is on 5G T-Mobile Home Internet <> Cheetah router <> BPI-R3 <> pfsense box <> house network.

I notice super activity graphs in the OpenWrt luci-statics for SQM.

Oh, this is with VPN ON!


?? you turned it off and it gets better?

By a super amount.

I will test further…

Seems so, I just tried in another profile of FireFox, my paranoid settings, and extensions, etc.

Same result, latency is now killer low. This is incredible.

Now to play with tuning SQM…

I also DON’T see any load increases, CPU, System, interrupts, nor temperatures.

This is like a major discovery, definitely for me.

i have a A without SQM…Fiber network 2Gbps/1Gbps i enabled HW offloading and WED.

the higher the speed, the less useful SQM is.

in my case, with 2Gbps it’s more useful to activate the HW NAT, because of this my cpuload is close to 0 when I download at high speed.

Yes, but this is a Quectel RM520N-GL 5G modem. Via CGNAT internet service, even. I never knew if my latency problems was due to the GCNAT service, or my modem link.