Directly Flash Ubuntu 20.04 onto eMMC from RKDevTools

Hello all, Recently seeking alternatives to Raspberry Pi.

Followed “Install Image with SDcard” section of to mirror the image in the to the SD card with RockChip Create Upgrade Disk Tool then inserted it to the Banana Pi.

The instruction says the BananaPi should first boot to prompt to remove the SD disk, then it will install to eMMC and directly boot into the system, but neither did I get the prompt to remove the SD disk, nor did it boot into the Ubuntu OS.

I only get a partial Builtroot OS with cat /etc/os-release is buildroot.

All inputs and outputs need to be done via the CH340 USB port, I only has a laptop with no external monitor for connecting to HDMI or external keyboards.

Thanks for helping.

Had same issue, I followed this and problem solved. hope this helps.

Could you elaborate? Where are you doing wipefs? You are imaging the SD bootable disk on a Linux machine? I don’t have a Linux machine available. I only have Windows.

wipefs is a program in Linux, you can try in Windows Linux Subsystem (WLS) but I don’t know if it will work the same, and Windows need to reboot if you install WLS.


You have to do “wipefs -a /dev/sd#” everytime before you copy image to SD card.

step1: sudo wipefs -a /dev/sd#

replace # with the letter your system is assigned to USB. sde,sdf…etc.

step2: sudo bpi-copy openwrt-mediatek-filogic-bananapi_bpi-r3-sdcard.img /dev/sd#

Thanks. I need to find a Linux machine somewhere at work.

I managed to install the openWRT with SD through the Windows Rockchip create upgrade disk tool. But when I did the same for the Ubuntu image, the image won’t overwrite the openWRT in the eMMC.

Do you have success in installing the Ubuntu image? I see a lot of openWRT here and there.

Why should a sd image overwrite emmc? You have to do it manually…what exactly do not work? If you try my images boot will stop at atf because emmc is tried first and contains old bootchain which is not compatible with the new on sd. You have to press maskrom button till you are in uboot,boot linux from sdcard and erase emmc from that running system

I dont know what you are talking about, why installing the Ubuntu image to Banana Pi?

Sorry for the late response. I believe they provide an official Ubuntu image on the Wiki page. Is there any reason to not use that Ubuntu image?

Sorry, I merely only run Openwrt on router board, no experience with running Ubuntu image on router. I’ve checked the Ubuntu image, the filename is “2022-12-18-ubuntu-22.04-server-bpi-r3-aarch64-sd-emmc.img” and is 7.1GB in uncompressed size, which suggest that you should copy it to SD card or EMMC and boot it there.

I am using BPI-R3 btw.

the image won’t overwrite the openWRT in the eMMC.

From what I am understand is that SD & EMMC share the same interface, thats why if you switched to SD interface then EMMC wont be accessible. And thats why Sinovoip instructed us to copy image from SD to NAND first, then from NAND to EMMC.

Sinovoip instruction:

Note: because SD card and EMMC device share one SOC’s interface, you need flash one SD image firstly, then R3 boot from SD card, then flash nand image into Nand, then change boot strap to boot from nand, you need flash EMMC image into EMMC. Finally you change bootstrap to boot from EMMC.

You can follow their detailed instruction on Bananapi org here.

You are mixing r2pro and r3 which are completely different boards

R2pro has 2 mmc controller in soc. And you should use an image for this board. Afair there is no mainline openwrt support for r2pro. Imho this board is more for server usage than for routing purposes because of bandwith limited between soc and switch to 1g (till someone figures out how to use hsgmii on rk3568).

Afair all official images require rk tools for windows. Only my 2 images (debian,ubuntu) can be flashed via dd or any other disk imager tool.

yes I realized, I was wrongly referred to R3. in such case I have no experience with regard to R2, you guys continue to discussion and hope he can solve the problem soon.

I merely only run Openwrt on router board, no experience with running Ubuntu image on router.

I think I made very clear in the title that my board is R2-Pro. Also, the image I used should suggest I am trying to install Ubuntu instead of OpenWrt.

Also, frank-w, if I download the official OpenWRT image into a SD and put the SD on the board and boot, the image seemingly was being written to eMMC because the serial terminal prompts me to remove the SD after a few seconds. If I do that and reboot, it boots into eMMC with the same OpenWRT image.

That’s right, I already carefully weighed all of my options. For routers, I already have some heavy Cisco gears. I also receive free routers from my Internet Service Provider periodically. I need the board to build a site-to-site VPN gateway and decode a few surveillance camera streams, so I need more CPU power than R3.

Yes,my comment was targeting james.

Thats why i pointing to my ubuntu-image.

Okay,you have openwrt on emmc. Rockchip has a strange boot-order: emmc first and if it not works then try sd. You can skip emmc with maskrom button to boot from sdcard again.

So the saga continues. I made a USB A male to male short cable this afternoon after some soldering and used RKDevTool to flash on the images through USB. The first time was the official Ubuntu Mate build. I can boot and interact as a desktop, but wasn’t satisfied because I want to get a version that has DSA (Distributed Switch Architecture) working. Then I flashed on the Ubuntu Server 22.04 from the Wiki link, then I bricked the Banana Pi!

I lost all serial console and video outputs, clearing the eMMC from the RKDevTool results in [Download Boot Failure]. The RKDevTool is in Chinese, which I know as well as English (I hope).

How to unbrick the Banana Pi now? Any thoughts?

You can skip emmc by pressing maskrom button and boot so any sdcard you like and erase emmc from linux userspace. But if board is electrical bricked,this will not help

Ok. Luckily the board is not electrically bricked, as far as I could tell. I waited for a week and retried to use the official RK USB eMMC flash tool (press MaskROM key first before plugging in the power cable. I find disconnecting the HDMI cable seems to help) and it worked again. The official BPi image Ubuntu desktop 22.04 image might be the problem as when I flashed on the desktop 20.04 image, and it worked. I am typing up this post on the RPi-Pro 2, in case you are all wondering.

I see the DSA seems to work on the 20.04 image as I can see “6 Wired connections” from the NetworkManager. Recall that the RPi-2 Pro board has two CPU GbEs and 4 GbEs from the MT3711 switch chip. Screenshot%20from%202023-01-08%2012-03-49

So I am going to make this board a 4-WAN-port router and add an IPsec keying daemon and add a WiFi 6 PCIe card… Lots of interesting projects.