Debian + docker + openwrt running on BPI-R1


We created a debian8 image running on BPI-R1, which is base on BPI Mainline kernel 4.2, and install docker 1.7.1. The purpose of docker is to run openwrt in it, and it works now.

You can get the openwrt docker image from sinovoip docker hub

$ docker pull sinovoip/bpi-openwrt $ docker run -d /sbin/init $ docker ps //get the container ID $ docker exec -i -t <container ID> /bin/ash

Now you are in the openwrt envrioment. change the passwd of root if you want login in by browser.

We also created Ubuntu and Raspbian image with docker installed to run openwrt, The three images will be published later.


I bought a BPI-R1 with this current operating system and version (comes from /etc/openwrt_release) : DISTRIB_ID=‘OpenWrt’ DISTRIB_RELEASE=‘Bleeding Edge’ DISTRIB_REVISION=‘r42830’ DISTRIB_CODENAME=‘chaos_calmer’ DISTRIB_TARGET=‘sunxi/generic’ DISTRIB_DESCRIPTION=‘OpenWrt Chaos Calmer r42830’ DISTRIB_TAINTS=‘busybox’

uname -a return this information : Linux RouterName 3.14.27 #1 SMP PREEMPT Mon Jan 12 17:04:15 CST 2015 armv7l GNU/Linux

I downloaded this Debian+docker+openwrt image to use it on my BPI-R1. The router is not connected to a display. It is just connected by LAN.

At boot with this Debian+docker+openwrt image I just got a blinking green led. It does not boot.

What is is wrong ? How to solve it ? What means this blinking green led ?

Sincerely thanks and have a nice day.

Miguipda :wink:


I just tested this Debian+docker+openwrt but … And understood now what is this heartbeat green led

As I do not have any HDMI display as so many other users I use this BPI-R1 as a router. It is its main use with those LAN ports then we can not use this image when it start. I presume it stay in Debian boot and wait for actions but if we can not access it by SSH or OpenWRT web interface it does not have use.

So please make a new image of this Debian+docker+openwrt by just already installed OpenWRT (on it) and give a SSH access to the main operating system (Debian). It could then allow us to use it as a router and then configure the main operating system (Debian) through SSH as a server for what we need.

Sincerely thanks and have a nice day.

Miguida :wink:

I’ve tried this. Just to avoid other people losing their time too - first of all, login information is incorrect. Login is root/bananapi, not pi/bananapi. It took me some time to guess. Second - this thing run Openwrt inside Debian and thats all, no practical use at all. You can’t use any tool from Openwrt to config anything because it use network information from Debian. So you have one network interface working on physical port 3 (WAN on device) and nothing more, no switch, no wifi. If you want more, first have to config it in Debian to show up in Openwrt and i’am not even sure if this will work, cose have no nerves to lose my time even more. And to be clear - no Luci outside the device, nor ssh. This thing on pictures above is from device browser itself. I don’t get whats the point of this if nothing can be configured from Openwrt, and these guys don’t bother to do it previously, making the whole ting pointless. Sorry for my bad english and sorry if i sound mad, but i’ve never seen anything working for this device yet, except some pure Openwrt images WITH external wifi module, internal is complete crap. Every image have some cons making it unusable, the above too. You have some desktop and aps and no network functionality. I have one request - just make ONE image turning this device into router - 2 vlans for 2 separate interfaces, functional wifi AP, even with external module if there is no other way with internal crap and some network manager to configure or workable Openwrt interface, not to dig into config files on thousands places and some minimal desktop environment for aps. Is it so hard? Or you will publish a bunch of images that doesn’t work by default and just losing peoples time?

1 Like

This seems to be the only strategy they have. Providing new and broken OS images every few days to create the impression these boards receive good support.