Can someone shere image for Bpi-64?

Good day. I am use this tread: Bpi-r64 quick start (boot from eMMC) and install OpenWrt (whitch named Lede) on router. But this is very very old bild. From this I cann’t install pacages from OPKG manager. Can someone share image with newer version of OpenWrt. I will be very thankful.

Sorry, I believe there is only one

Hi. Thank you for link, but there only Debian image for Bpi-64.

You could try my debian-image and unpack self built openwrt-rootfs to root-partition

Hello. Can you more explain what I need to do please. Step by step if it possible.

If I try self built Openwrt I get same two *.bin file witch I can download from Openwrt unstable fork:

Not use bin files…you can select tar in menuconfig and then compile by yourself

Yes I get *.tar.gz file but I don know what to do with it.

I have not tried it yet,but user @smaller09 reported here for r2: Porting openwrt(kernel 5.4) for bpi-r2 status report

I can not carry out this.

I got it working for r2 using my existing debian lmage,adding additional partition #3, unpacking rootfs to it and changing root-var in uEnv.txt to it…

It is very difficult for me. I will wait stable release Openwrt.

have tried for r64, but compilation of gcc failed because of missing PLO-files…don’t know how to solve, made distclean and can’t download some packages atm

retried after distclean…can open kernel_menuconfig but have to patch out wmac-node in build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/linux-5.4.28/arch/arm64/boot/dts/mediatek/mt7622-elecom-wrc-2533gent.dts to get kernel compiled…

uploaded basic bpi-r64/bpi-r2 rootfs here: for testing the unpack-way

Today I am install development snapsot OpenWrt and suddenly it working. Honestly I can not install Luci. But daily snapsot working unlike previous.

root@OpenWrt:~# uname -a
Linux OpenWrt 5.4.28 #0 SMP Mon Apr 6 15:08:38 2020 aarch64 GNU/Linux

I am add that Openwrt dont save settings.

I am remove issue with settings. This is because I am use initramfs image, only sysupgrade image can save settings.