Can someone provide a simple How To for a BPI-W2? yes im a n00b on these

Apologies for what is clearly a n00b problem.

Just like user k_bergeron, I’ve set up countless Raspberry Pis by simply burning a image to an SD and plugging them in. I’ve got ~8-10 in my house running node.js and python doing everything from my garage door to temp sensors on my plants but I Cannot get this Banana Pi to boot.

I’ve been through this for months now and had no success. The document seems to imply a lot more knowledge than a new Banana Pi user has. Do I really need to connect a debug cable? do I really need to mess with the eMMc? Cant it just boot from an SD card? Where am I putting the u-boot.bin? is it just copied or is there an image to burn? Is there no way to do it without tftp from another linux box?

Can anyone out there Please give me a simple step by step to get a BPI-W2 v1.1 up and running on Raspbian (or really any linux distro)?

I’ve taken a 64GB SD card and, using Win32 DiskImager, burned 2018-09-17-raspbian-stretch-demo-bpi-w2-sd-emmc.img to it from the link provided. I’ve created a second partition of ~100MB and copied, bpi-w2.dtb and uImage to it. Set the dip switch to both possible positions and after power up there is nothing apart from lights showing it has power.

I would love a simple, concise, how-to like this:

  1. set dip switch to position 1
  2. grab this image: “some image” and use win 32 disk imager to burn to SD card
  3. Copy “these files” to “here”
  4. Sacrifice a chicken under the full harvest moon
  5. Cross your legs and fingers while whistling Jump Around by House of Pain
  6. Power up the Banana Pi. (hopefully 4 and 5 aren’t necessary but at this point…)

The Getting started doc is confusing unless, seemingly, you’ve already set up a Banana. Honestly I’m sorry to have to post this. I hate having to ask for help but I’ve got no hair left to tear out.

Thanks in advance.

100 mb partition and manually moving bluecore and stuff was not needed when you burned complete image.

I have not tried rasbian (running Ubuntu on my box) but image is whole package.

Guide you saw on wiki was meant for older Ubuntu build - there was no image ready at first - you needed to partition and fill data on SD yourself.

Simply burn image and push it in banana. Sw4 (next to 40-pin gpio) to position 1 and plug power (board boots with power plugged due to some bug - power button is not needed)

If that won’t work - there would be additional step required: update SPI rom (via usb-c cable, Windows machine as in guide on this forum) Usb-c serves as power in as well - board will boot pulling power from your computer.

Thanks Kamil. Reburned the image on the SD, plugged it in…to no avail. Now I’ve gone through the first stages of updating the SPI rom via usb-c but of course now i’m into homemade debug cables, Putty etc. and so far the board isnt talking. ROM updated fine though via usb.

Appreciate the help. The BPI is a black box and isnt giving any hints around why it wont answer over the debug. I’ll keep plugging away.

For anyone else searching it out, here is the link to the How To W2 SPI Rom Update: And link to the ROM tool: Those two came from here:

When you mentioned homemade debug cable - I hope you are using USB -> UART bridge here, not just plain cables.

I got one like this - not bought from this exact store, just googled for model.

GND / RX / TX plugged to 3 pin UART between SD slot and power button.

Check device manager to see where your USB got detected (depending which USB port on my laptop I use - my bridge is detected as COM4 or COM6 - yours might be completely different)

Just to cover it all: GND on USB goes to GND on board, then you cross RX -> TX, TX -> RX

Mine just worked - hard for me to tell what might be wrong on your side.

“Home made” just from the Banana’s header to the rs232 end of the USB-to-serial UART cable. The USB was detected as COM3 and from what I read I should be using 115200bps 8/N/1. Correct? Should the board be plugged into my pc usb port or just power? (I dont know if it matters but thought I’d ask. I’ve tried both). There is no feedback from the board about state; which is aggravating. No flashing light saying what condition it’s in. just solid red, green and blue.

Does the board Always dump info out the Debug header or only when it is in a certain state? Meaning do I need to power it up in a particular way to connect?

Right now, the DIP is in position 0, USB-C is plugged in to the wall for power, debug and USB cable connected, Putty open and listening on COM3 at 115200…and nothing but solid lights. Inscrutable.

Thanks and I really appreciate the time.

Strange. For me it stars pushing strings to uart as soon as you plug power in.

With sw4 on 0 it is supposed to boot from emmc only. With sw4 on 1 it is either SD only (old SPI rom) or ‘try SD, fallback to emmc if no SD detected’ (new SPI rom)

RGB LEDs are all lit on my board as well.

In either case you should at least see it trying to look for boot stuff

i’ve hooked up the oscilloscope to the debug header on the board and I dont think I’m seeing anything. I’m going to grab the same (or close to) UART board you’ve been using, set things up exactly as you’ve had it and see where it goes from there. Who knows. Thanks again.

alright. It speaks. rebuilt my cable and swapped my uart cable for the device you used and viola. it speaks. so, with some hope I ask…what now? What do I need to do to this thing to make it boot from the SD card now? I feel so close I can taste it.

fall back to ubuntu release 2018-09-17 topic:

If your board startup log print “SPI ROM:20180907”, then you don’t need to update spi rom.

when you mentioned procedure via USB went well - this should look exactly as in that other topic (step 4)

  • get image from step 3 link, 3
  • burn it on SD (I have used etcher on windows laptop to burn SD)
  • plug it back to bpi
  • sw4 on ‘1’
  • power board - should boot to ubuntu now (watch uart session for errors - set putty session logging / grab output by mouse and attach file here - will be easier to see what might be wrong in your scenario)

Except that I’ve burned the SD image onto the SD card, set the switch to 1 and it wont boot. hence the boot to debug with switch = 0. I’ve lost track but I think that’s where we started:

“I’ve taken a 64GB SD card and, using Win32 DiskImager, burned 2018-09-17-raspbian-stretch-demo-bpi-w2-sd-emmc.img to it from the link provided. I’ve created a second partition of ~100MB and copied, bpi-w2.dtb and uImage to it. Set the dip switch to both possible positions and after power up there is nothing apart from lights showing it has power.”

So, the image is burned properly but no boot. Now I’m in debug but no idea what to look for. Any ideas?

I’ve created a second partition of ~100MB and copied, bpi-w2.dtb and uImage to it.

This is your mistake. Just burn the image and unplug it from your laptop. the image is complete, like for raspberry.

Hey Kamil. I was just typing an addendum to point out that i was merely copying the paragraph from my first post. The image on the SD card is the exact image downloaded from the site and burned with win32 disk imager. that was basically where i started the second post of this thread. The board wont boot. I’ll try some other images maybe. if none work I’m giving up and tossing these things. The time was much appreciated but it seems these things may not be ready for primetime. Cheers

have you been able to get it to work i’m having the same issue burned the image to an sd card but it wont boot

Hello, which image did you download?

what is the version of spi rom in your log?


Did you switch SW4 to 1?

could you please show me?

I’ve had troubles too with flashing the SPI and booting from SD card. I had to read a lot in the forum and the Word documents provided with the zipped tools linked in the *nix-images threads. The wiki page was more puzzling than helpful. So this is my step-by-step guide for everyone just trying to understand what needs to be done.

  1. You need
  • a USB-C cable
  • a USB2Serial adapter (e.g. with a CP2102 chip) for the UART connection
  • a terminal software like putty (Windows) or minicom (Linux)
  1. UART
  • The thread Using Debug UART was helpful
  • Only with the adapter you can access the debug console via putty/minicom and see the boot process (and the SPI-ROM version)
  • the adapter needs drivers which you can download from the adapter manufacturers website
  • the UART pins on the BPI-W2 are the three pins between SD card slot and Power/Reset-Switches
  • You need to connect TX, RX and GND; you have to cross TX and RX, meaning TX on the USB adapter goes into RX on the BPI-W2 and viceversa for RX
  • These are the connection settings you have to set in putty or minicom: speed 115200, data bits 8, parity none, stop bits 1, flow=off
  • You should see text output in putty/minicom as soon as you established a connection and then powered on BPI-W2
  1. Check the SPI ROM version
  • There is a switch called SW4 on the BPI-W2 on the boards side where the 40-pin-connections are
  • The SW4 switch needs to be in position 1
  • Remove the SD card from the slot if inserted
  • Connect the UART, establish the connection in putty/minicom, power on the BPI-W2
  • Check if the console outputs something like “Banana Pi BPI-W2(SPI ROM:DATE)” where DATE is (while I’m writing this) 20180907. Check with the screenshot in one of the image threads (see next section)
  • If you have the right version, you don’t need to flash the bootloader and can skip to section 5
  • if you are having problems booting the *nix image from SD card check the last two bullet points of section 4
  1. Flashing the SPI ROM with the bootloader
  • This is a two part process: transfering the img-file via usb-c, flash via the UART debug console
  • You can find the instructions in the Word document “W2 SPI ROM Update.doc” which you can get through one of the image threads (e.g. BananaPI-W2 Ubuntu 18.04 New Image Release 2018-09-17) by using the link “How-To Update W2 SPI ROM”
    • Possible problem nr1: you are not able to install the USB-C-driver for the board
      • Note: the Windows device manager may tells you that the device isn’t able to start
      • Solution: the switch SW4 has to be in position 0 for the whole process
    • Possible problem nr2: copy the command line commands from the document, do not type them manually
  • Summary of the Word document:
    • download and extract the zip file with the SPI ROM Tool called Kylin_USB_Tool (find it through one of the image threads like before)
    • switch SW4 to 0 (this is not in the document), press and hold the USB button
    • plug in the USB-C cable while holding the USB button
    • install the driver from the extracted zip, normally it needs to be done in the Windows device manager
    • start the rtumdfsample.exe from the extracted zip
    • load the image file from the zip by clicking the “open” button
    • click on the green android logo called “Device 01” and wait for it to finish with 100%
    • power off the BPI-W2, open putty or minicom, connect UART if not already, establish connection
    • power on the BPI-W2, press the RST (reset) button on the BPI-W2
    • copy the two commands to the command line and execute them one by one (rtkemmc read 0x01500000 91286 700000) (chain 0x01500000)
    • power off BPI-W2, SW4 switch to 1, insert the prepared SD card (see next section), power on
    • maybe watch the boot process through UART, it will not show on the HDMI-connected Display
    • Possible problem: it has finished booting but there is no HDMI-signal
      • possible solution nr1: it could be the image (or better the kernel in the image), try another image (e.g. Rasbian, Ubuntu…)
      • possible sulution nr2: it is not switching to the X-Server, try pressing Ctrl+Alt+F7 (or try it with F5, F6 then F7)
  1. Preparing the SD card
  • there is an manual way and a image-ready way
  • the manual way is to format the SD card in partitions as mentioned on the wiki page
  • the image-ready noob way is to use a formatting tool like Balena Etcher and write the image file provided in one of the image threads (see before) to the SD card, no need for manual partitioning and formatting
  1. Sacrifice a chicken under the full harvest moon, Cross your legs and fingers while whistling Jump Around by House of Pain like @Zleaguer proposed :stuck_out_tongue:

Hope I didn’t make mistakes. If you find any, please report it so I can change it :+1:

hi, would you please so kind and tell the world, where we can find the image file 2018-09-07-lk-spirom-bpi-w2-for-usb-mptool.img thank you

ok, found it!