[BPI-R64] sata activate

Tell me please! How to make the hard drive (sata) work on BPI-R64 OpenWrt? which modules to add to the assembly?

Afaik you need to enable sata in dts and disable pcie1,because they share same pcie-port on soc



Also on sata-phy



maybe asm_sel needs to be set to output-low, have done all 3 and see my connected hdd

sata.patch (635 Bytes)

root@bpi-r64:~# cat /proc/partitions                                            
major minor  #blocks  name                                                      
 179        0    7634944 mmcblk0                                                
 179        1     262144 mmcblk0p1                                              
 179        2    7105536 mmcblk0p2                                              
 179       24   31166976 mmcblk1                                                
 179       25     262144 mmcblk1p1                                              
 179       26    7105536 mmcblk1p2                                              
   8        0  732574584 sda                                                    
   8        1     307200 sda1                                                   
   8        2     614400 sda2                                                   
   8        3     131072 sda3                                                   
   8        4   52068289 sda4                                                   
   8        5     358400 sda5                                                   
   8        6   15728640 sda6                                                   
   8        7  227866624 sda7                                                   
   8        8  414515200 sda8                                                   
   8        9   20981760 sda9

Thanks !!! done!!! here is a link to the assembly with a working image OpenWrt with support for HDD. https://drive.google.com/drive/folders/1VQ7e4uyw4oTB1whDGXAPrhgnJZW3fM3U?usp=sharing

Hello again and a happy new year!

Found a R64 under the christmas tree and obviously there’s something missing. I applied the patch and activated sata in the config, but alas: no disk showing up!

Can you help?

Just try my sata patch modifying dts (enable sata node and change asm_sel) :slight_smile: see my previous posting. Imho i have already enabled it in 5.4-r64-main


A happy new year to you too

That’s what I did - with only one difference: In mt7622-bananapi-bpi-r64.dts it is always spelled “okay” instead of “ok”, so I chose okay. Is that the problem possibly?

Tried “ok” - no change, seems to work - or better “not work” anyway.

By the way: my plan is to make it a backup-storage, found a couple of 1TB disks in the workshop and got myself a SATA-multiplexer and a nice 4-disk-hotplug-housing from aliexpress. This setup works fine for the R2, now let’s see for the R64. :wink:

Oh,you’re right…it should be “okay”. But Both are checked: https://github.com/frank-w/BPI-R2-4.14/blob/4da7b54690665353f469799733d689e23d5b7407/drivers/of/base.c#L568

Maybe a power issue? Have you set gpio90?

I will rebase 5.4 again after some other things fixed/tested

You loaded the right dtb?

What should I do about GPIO 90? Set to output-low? Yeah, did that.

In fact, I consider myself as silly/stupid … I think I just missed something. Remember I had the same problem with the R2.

Oh you know sometimes I hate myself for ordering things which I can’t really comprehend. A couple of days ago my wife gave me an oscilloscope for birthday … still no idea how to use :smiley:

So I found my silly mistake:

Your tree / your scripts generate BPI-BOOT in ./linux-4.19 and I always kept fiddling in ./linux. So there could be no change whatever I did :wink: Maybe it’s time for an appointment with my optometrist for some new glasses.

Anyway, everything runs like a charm. By now it’s only a tabletop-setup with a SSD rudely plugged upright into the board. Next task is mounting it into the good old SCSI-case (100w power-supply, 4 inch Power-Fan, two 5.25 drive-slots for the HDD cradle an maybe a Tapedrive one fine day)

Thanks much for your help!

And now I got my things running I checked the Disk-Performance with Samba-Shares:

  • Synology DS218+…: 112 MB/s
  • R64…: 112 MB/s

Looks like 1 GBit :wink: Quite fine!