BPI-R64 Ethernet Ports Not Enabled for Gigabit Speed

Hi,

I have OpenWrt version: OpenWrt SNAPSHOT, r18394-962c585580 Installed on my BPI-R64

And the Ethernet ports seem to be capped at 100 Mbps even though they are supposed to be Gig Ethernet ports.

I can measure the internet speed upstream from the BPI-R64 router and the speed is ~800 Mbps, plugging a computer directly into any of the BPI-R64’s Ethernet ports results in speeds of ~80 Mbps.

Is there some firmware setting that has to be updated for the Ethernet ports to be capable of Gig Ethernet speed?

Thanks in advance for any help

You can try these steps: [BPI-R2] SD card image with Openwrt 19.07 imgbuilder

I wonder about really slow speed here…maybe check for errors on lan ports/eth0 with ethtool and maybe soldering/lan-cable

Hi Frank, It looks like the OpenWrt imgbuilder is for the BPI-R2. Will that also work on the BPI-R64? The only OpenWrt release for the BPI-R64 is a Snapshot and not an actual release. I would rather be on an actual release, so if I can use it I will probably try and switch to it.

The results from ethtool seems to suggest that the port are set for 1000Mb/s, but that is not the speed I am getting.

ethtool results: [email protected]:~# ethtool eth0 Settings for eth0: Supported ports: [ MII ] Supported link modes: 2500baseX/Full Supported pause frame use: Symmetric Receive-only Supports auto-negotiation: Yes Supported FEC modes: Not reported Advertised link modes: 2500baseX/Full Advertised pause frame use: Symmetric Receive-only Advertised auto-negotiation: Yes Advertised FEC modes: Not reported Link partner advertised link modes: 2500baseX/Full Link partner advertised pause frame use: Symmetric Link partner advertised auto-negotiation: No Link partner advertised FEC modes: Not reported Speed: 2500Mb/s Duplex: Full Port: MII PHYAD: 0 Transceiver: internal Auto-negotiation: on Current message level: 0x000000ff (255) drv probe link timer ifdown ifup rx_err tx_err Link detected: yes [email protected]:~# ethtool lan3 Settings for lan3: Supported ports: [ TP MII ] Supported link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Full Supported pause frame use: Symmetric Receive-only Supports auto-negotiation: Yes Supported FEC modes: Not reported Advertised link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Full Advertised pause frame use: Symmetric Receive-only Advertised auto-negotiation: Yes Advertised FEC modes: Not reported Link partner advertised link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Full Link partner advertised pause frame use: Symmetric Link partner advertised auto-negotiation: Yes Link partner advertised FEC modes: Not reported Speed: 1000Mb/s Duplex: Full Port: MII PHYAD: 3 Transceiver: external Auto-negotiation: on Supports Wake-on: d Wake-on: d Link detected: yes

please post your out put in code-tags (select the text and press the <> button).

with ethtool i meant the statistics

ethtool -S interface

to see if there are CRC errors, dropped packets and such

and the other thread is mention rps, cpu affinity and hwnat. without them much traffic is done by (single) CPU and this reduces throughput. These are independ of SOC (at least r2 and r64 are using it). you can look on cpu load and interrupts to see if this is the bottleneck.

In your case 80Mbit/s are really less throughput, i guess more a HW problem or maybe the temperature throtteling again…not sure this is fixed on openwrt