[BPi-R4] MT7916 6ghz won't start *SOLVED*

I can not get the 6ghz to start. I have kmod-mt7916 firmware and kmod-7915e driver both loaded. My regulatory domain confirms I am allowed to use 6ghz. When I set the radio to 6ghz it just goes to disabled. As soon as I set it back to 5ghz it works. It works flawlessly on 2.4Ghz and 5Ghz. Any clues?

If anyone else is having issues with the AsiaRF-MT7916 I’ll explain what I did to make everything work.

I built my own image based on openwrt’s github. To make the MT7916 work it’s required to add kmod-mt7916-firmware, kmod-mt7915e, and wpad-basic-openssl.

After I booted the image I selected the correct regulatory domain in the adapter settings and verified 6ghz was allowed and on what channels/width it was allowed. After that I used luci to select 6ghz using the 5Ghz/6Ghz switch in the adapter settings. Then you must set WPA3 security AND Management Frame Protection to required in wireless security under adapter settings.

After that I selected channel 21 and it worked perfect on 6ghz. Initially most other channels didn’t work. After a couple reboots all channels are now working.

2 Likes