Write a bash script that pings the local ip of the web interface perhaps.
I was able to get the Alcatel Lucent G-010S-P working well with the OpenWrt snapshot build using the attached patch I made. It’s essentially a backport of sfp.c from the latest Linux kernel, with changes to apply the long startup, los, and tx fault quirks to the module.
999-G010SP-sfp.patch (7.8 KB)
Hello there,
I’ve tried to apply this patch to openwrt-23.05 branch placed it target/linux/mediatek/patches-5.15/999-sfp.patch here and it was rejected. Could you please provide more information about branch and commit that had been used?
The patch looks like it is defined for later kernel version than 5.15 like 6.1 or 6.6 as 5.15 had completely different code for sfp quirks. So try 6.1-patches or 6.6-patches folder and switching to this kernel
I used the snapshot/main branch, the patch is for kernel 6.6. frank-w is correct, the code changed a lot between kernel versions.
Thank you for your response.
You were right; it works significantly better than 5.15. The interface is up and works without the optical cable plugged in, and it starts up right after plugging it in.
However, the fix doesn’t resolve the ‘EEPROM base structure checksum failure: 0x7c != 0x00’ error after a soft reboot.
There is this solution I found on few discussion forums:
Some guy from Poland made videos about their ONT and GPON Stick - he was using bananapi bpi-r3 https://youtu.be/IlKq2H1H3-0?si=hV7EA2Ih6cOn2vfz
Hello, today i decided to test my Nokia G-010s-P in my BPI-R3 with the latest Openwrt 23.05.5 and it doesn’t work anymore. At the begining of this topic, we made it working and i think but not sure it was working with the first stable version of openwrt supporting the BPI-R3.
Today i’m getting this message when i plug the ONU in the SFP-1 port :
Mon Dec 23 13:29:04 2024 kern.info kernel: [ 255.859645] sfp sfp-1: module ALCATELLUCENT G010SP rev 10 sn ALCLFAB44018 dc 161205
Mon Dec 23 13:29:04 2024 kern.err kernel: [ 255.932493] sfp sfp-1: module transmit fault indicated
Mon Dec 23 13:29:09 2024 kern.err kernel: [ 261.340045] sfp sfp-1: module persistently indicates fault, disabling
My MA5671A is working fine.
Did they remove the patch/Quirk @Dale made ??
if i watch here : linux/drivers/net/phy/sfp.c at master · torvalds/linux · GitHub i can see this :
static const struct sfp_quirk sfp_quirks[] = {
// Alcatel Lucent G-010S-P can operate at 2500base-X, but incorrectly
// report 2500MBd NRZ in their EEPROM
SFP_QUIRK("ALCATELLUCENT", "G010SP", sfp_quirk_2500basex,
sfp_fixup_ignore_tx_fault),
My kernel version in openwrt is : 5.15.167
Try to switch to kernel 6.6
I’d like to avoid having to compile my own version…
how do I know if this quirk still exists in my kernel?
is there a link online to see the contents of this file for my version of openwrt?
Afaik openwrt ahows its code state (git sha1 hash) in terminal banner/luci-info. With this hash you can show code state in openwrt git repo.
I’m not sure where openwrt adds patches for sfp core,but if there is none you can look in linux source with your kernel version.
You pointed to torvalds/master,not your kernel version.
For openwrt i’ve found only this
Which maybe related
Thanks ! well, so according to your link, the G-010S-P should be supported…so what’s going on…
not sure it’s the same module as it says 3FE46541AA instead of G010SP
if (!memcmp(id.base.vendor_name, "ALCATELLUCENT ", 16) &&
!memcmp(id.base.vendor_pn, "3FE46541AA ", 16))
Then it is not the same…is your string there too? Maybe try another quirk/fixup (e.g. the bootup delay)?
i was told that kernel 6.x will be used in the next openwrt 24.x, in a couple of weeks…So let’s wait for it
@frank-w My gpon stick is working with openwrt 24.10.0.
After I remove eth1 from wan and add new interface static address, I can ping my stick from router
root@OpenWrt:~# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: seq=0 ttl=64 time=0.731 ms
64 bytes from 192.168.1.1: seq=1 ttl=64 time=0.355 ms
64 bytes from 192.168.1.1: seq=2 ttl=64 time=0.419 ms
64 bytes from 192.168.1.1: seq=3 ttl=64 time=0.393 ms
64 bytes from 192.168.1.1: seq=4 ttl=64 time=0.359 ms
64 bytes from 192.168.1.1: seq=5 ttl=64 time=0.263 ms
But I can’t ping or access stick from my PC
Mac ~ % ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1): 56 data bytes
92 bytes from openwrt.lan (192.168.100.1): Destination Port Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 5400 97e3 0 0000 3f 01 fcf8 192.168.100.123 192.168.1.1
Request timeout for icmp_seq 0
92 bytes from openwrt.lan (192.168.100.1): Destination Port Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 5400 1f1f 0 0000 3f 01 75bd 192.168.100.123 192.168.1.1
Request timeout for icmp_seq 1
92 bytes from openwrt.lan (192.168.100.1): Destination Port Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 5400 9042 0 0000 3f 01 049a 192.168.100.123 192.168.1.1
Request timeout for icmp_seq 2
92 bytes from openwrt.lan (192.168.100.1): Destination Port Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 5400 1ee8 0 0000 3f 01 75f4 192.168.100.123 192.168.1.1
Interface
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fddc:a448:e755::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'sfp2'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.100.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'br-wan'
option type 'bridge'
list ports 'wan'
config device
option name 'wan'
option macaddr '3e:9b:90:6f:16:40'
config interface 'wan'
option device 'br-wan'
option proto 'dhcp'
config interface 'wan6'
option device 'br-wan'
option proto 'dhcpv6'
config interface 'GPON'
option proto 'static'
option device 'eth1'
option ipaddr '192.168.1.5'
option netmask '255.255.255.0'
My gpon stick is GPON ONU Stick 1.25G/2.5G ODI DFP-34CX-2C2 HSGQ SFP XPON ONU Stick
Do I need to use custom firewall rule or something?
PS: It’s the same as you’ve guessed, I need to plug fiber in order to access gpon stick.
You need to enable routing on r4 and tell your pc that it can reach the gpon subnet over your r4 lan address (but seems your pc config is right).
For deeper analysis you can start tcpdump on r4 lan interface and capturing icmp packets.
in your br-wan device there is no eth1 ports ?? it should be like this :
config device
option name 'eth1'
option macaddr '3e:9b:90:6f:16:40'
config device
option name 'br-wan'
option type 'bridge'
list ports 'eth1'
list ports 'wan'
and add ‘br-wan’ in your gpon interface :
config interface 'gpon'
option proto 'static'
option device 'br-wan'
option ipaddr '192.168.1.5'
option netmask '255.255.255.0'
do not use capital letters for interface names.
This works well for me since i have my BPI-R3
Thanks guy. It worked.
Hello, since openwrt 24.10, when i reboot the BPI-R3, my gpon ONT Nokia G-010S-P display this message at startup : EEPROM base structure checksum failure: 0x7c != 0x00
root@OpenWrt:~# logread | grep "sfp"
Thu May 8 09:54:52 2025 kern.info kernel: [ 12.562771] sfp sfp-1: Host maximum power 3.0W
Thu May 8 09:54:52 2025 kern.info kernel: [ 12.567825] sfp sfp-2: Host maximum power 3.0W
Thu May 8 09:54:52 2025 kern.err kernel: [ 12.891510] sfp sfp-1: EEPROM base structure checksum failure: 0x7c != 0x00
Thu May 8 09:54:52 2025 kern.err kernel: [ 12.898467] sfp EE: 00000000: 03 04 01 00 00 00 00 00 00 00 00 03 19 00 00 c8 ................
Thu May 8 09:54:52 2025 kern.err kernel: [ 12.907143] sfp EE: 00000010: 00 00 00 00 40 40 42 40 40 41 00 00 00 00 00 00 ....@@B@@A......
Thu May 8 09:54:52 2025 kern.err kernel: [ 12.915818] sfp EE: 00000020: 00 20 20 20 00 00 00 00 46 00 11 10 41 50 00 00 . ....F...AP..
Thu May 8 09:54:52 2025 kern.err kernel: [ 12.924493] sfp EE: 00000030: 00 00 00 00 00 00 00 00 30 30 20 20 01 14 00 00 ........00 ....
Thu May 8 09:54:52 2025 kern.err kernel: [ 12.933167] sfp EE: 00000040: 40 b7 ba 7f 80 ff ff ff 20 3d f8 80 c0 ff ff ff @....... =......
Thu May 8 09:54:52 2025 kern.err kernel: [ 12.941842] sfp EE: 00000050: fc 7e 07 80 c0 ff ff ff 30 3d f8 80 c0 ff ff ff .~......0=......
Thu May 8 09:54:52 2025 kern.info kernel: [ 12.980030] sfp sfp-2: module OEM SFP-2.5G-T-R-RM rev 1.0 sn 2412190031 dc 241219
Thu May 8 09:54:54 2025 kern.info kernel: [ 15.657039] mt7530-mdio mdio-bus:1f sfp2: configuring for inband/2500base-x link mode
Thu May 8 09:54:54 2025 kern.info kernel: [ 15.658782] br-lan: port 5(sfp2) entered blocking state
Thu May 8 09:54:54 2025 kern.info kernel: [ 15.658804] br-lan: port 5(sfp2) entered disabled state
Thu May 8 09:54:54 2025 kern.info kernel: [ 15.658852] mt7530-mdio mdio-bus:1f sfp2: entered allmulticast mode
Thu May 8 09:54:54 2025 kern.info kernel: [ 15.661098] mt7530-mdio mdio-bus:1f sfp2: entered promiscuous mode
Thu May 8 09:54:59 2025 daemon.notice netifd: Network device 'sfp2' link is up
Thu May 8 09:54:59 2025 kern.info kernel: [ 20.569236] mt7530-mdio mdio-bus:1f sfp2: Link is Up - 2.5Gbps/Full - flow control off
Thu May 8 09:54:59 2025 kern.info kernel: [ 20.569435] br-lan: port 5(sfp2) entered blocking state
Thu May 8 09:54:59 2025 kern.info kernel: [ 20.569444] br-lan: port 5(sfp2) entered forwarding state
so my ONT doesn’t work until i take it out and put it back in its SFP cage.
Thu May 8 09:57:42 2025 kern.info kernel: [ 183.978797] sfp sfp-1: module removed
Thu May 8 09:57:46 2025 kern.info kernel: [ 187.645213] sfp sfp-1: module removed
Thu May 8 09:57:46 2025 kern.info kernel: [ 187.981352] sfp sfp-1: module ALCATELLUCENT G010SP rev 10 sn ALCLFAB44018 dc 161205
i don’t have this problem with my other ONT Huawei MA5671A.
How can we fix this problem ?