BPI-R3 using both SFP as LAN

I’ve just got my BPI-R3 and planning to use it as OpenWRT router. I wanted to know if both SFP ports can be used as LAN, (I’ll be using 1Gb port used as WAN since my ISP ~ 400mb).

Thanks

Should be possible because these are only interfaces…just move wan (switchport afaik named differently in openwrt) out of lanbr and the sfp interfaces into it

1 Like

I was worried it might be hardware-bound.

I’ll give it a try. Thanks

I’ve got my BPI-R3 and did as you said. It did not work.

I’m using the WAN port to connect to my modem. When I plug my PC to sfp1, I don’t get an IP.

Here’s my network config:

>_ cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fddb:f70f:69da::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.0.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '56:c8:b5:c7:2e:0c'

config device
	option name 'eth1'
	option macaddr '56:c8:b5:c7:2e:0c'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'br-wan'
	option proto 'dhcpv6'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'


You need to remove eth1 and option device ‘br-wan’ from the wan bridge

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fddb:f70f:69da::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.0.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '56:c8:b5:c7:2e:0c'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'

Thanks @AntonyFl for your help.

I’ve managed to get it working. The source of the problem was that I needed to reboot the router for changes to work (the “refresh” and “save changes” did not help). I did not know if the changes I applied were correct or not to earn a reboot.

As you’ve stated, the working config.

# >_ cat /etc/config/network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fddb:f70f:69da::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.0.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'br-wan'
	option proto 'dhcpv6'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'