BPI R3 openwrt update snapshot packages on emmc

I am trying to upgrade the openwrt firmware on emmc but unable to do it. I had ver 21 snapshot at first and load that from sd card and to emmc but now i have firmware snapshot ver 22 which is in SD card and can boot from sd card but unable to load on emmc. After changing the dip switch also i am seeing firmware ver snapshot 21 on emmc. Any help will be appreciated?

What you mean by that? OpenWrt 21.02.x never officially supported the BPi-R3. So maybe you mean SinoVoip’s build of MediaTek’s SDK (which is a fork of OpenWrt 21.02)?

Do you have the serial console connected?

If so, then you can select to install to SPI-NAND while booting from SD card, and then from there to eMMC. This is described in great detail in many posts here in the forums, but feel free to ask if you need more assistance.

Thank you . Was able to configure. Attached is the screenshot. But now i am having a issue on installing any packages as some of the packages are 5.15.104 and as i was trying to use 5.15.98 which is my kernel version was not able install. it just gives me a error on dependencies. for example i was trying to install kmod-usb-option but could not install package. I tried by downloading manually for 5.15.98 and upload got the same error. Any help would be appreciated. 04%20AM

1 Like

What build are you using that uses kernel 5.15.98?

To be able to use downloaded kernel modules (from OpenWrt), there are two requirements:

  1. The kernel module must be of the same kernel version
  2. The kernel module must have been compiled with the same kernel options

OpenWrt’s build system creates a “vermagic” hash of the kernel configuration and uses this to ensure the kernel modules you are downloading were compiled with a compatible set of options to the kernel on your device. You can see your kernel version and hash with the command: opkg list-installed | grep kernel

kernel - 5.15.104-1-13a7281cb2e6954f8fdd31c9fb1a2802

Now go to: https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/kmods/ and check to see if there are any kernels there which match your version and hash. If not, then you are not using an OpenWrt build that you can download and use kernel modules from.