BPI-R3 not booting for Yocto image

Hi, I am started yocto for BPI-R3, added below machine configuration for uboot and generated image.

PREFERRED_PROVIDER_u-boot-fw-utils = "libubootenv"
PREFERRED_PROVIDER_virtual/kernel = "linux-mediatek"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot"
UBOOT_CONFIG = "mt7622_rfb_defconfig"
UBOOT_ARCH = "arm64"
UBOOT_LOADADDRESS = "0x48080000"
UBOOT_ENTRYPOINT = "0x48080000"

Below “system halt error” getting on serial terminal

F0: 102B 0000
FA: 1040 0000
FA: 1040 0000 [0200]
F9: 103F 0000
F3: 1001 0000 [0200]
F3: 1001 0000
F6: 300C 0028
F5: 4801 0000
00: 1005 0000
FA: 1040 0000
FA: 1040 0000 [0200]
F9: 103F 0000
F3: 1001 0000 [0200]
F3: 1001 0000
F6: 300C 0028
01: 102A 0001
02: 1005 0000
BP: 2000 00C0 [0001]
EC: 0000 0000 [3000]
T0: 0000 0109 [010F]
System halt!

do we need any extra configuration required for yocto build?

Where do you define atf? System halt means that bootrom does not find bl2 (its header). Which uboot config/build-params are used?

This doesn’t look like it can work in mt7986-based BananaPi R3…

Hi I am also facing same issue. I have used the - mt7986_rfb_defconfig boot config but still facing System Halt error. Any help would be appreciated.

Same answer as above…you need to use mt7986 bootchain (atf) to get it booted…

Hi, I’m new in banana pi. here also facing the same issue. Regarding this as per the above comment make changes in meta layer of filogic as UBOOT_CONFIG = “mt7986_rfb_defconfig” still get the same system halt error. Even try with this one UBOOT_CONFIG = “mt7986a_bpir3_sd_defconfig” still not able to boot up.

Any help

Do you all read what i write?

You talk about uboot config,but you first need bl2 which is built from atf code. I do not know yocto,but it needs to build somehow the mt7986 bl2 to get r3 booted.

I am building kernel, u-boot with atf-mt and flashed in to sd card, my yocto rootfs i copied to sd card in separate root partition, now it is booting and my issue resolved

1 Like

For the first parts you can also use my precompiled image from uboot-repo and kernel is also available as package…for anyone not want to compile all himself…maybe aarch64 yocto rootfs is available or you can share yours.

I guess that misses the point of Yocto/OE, which is to build very customized firmware and “rendering” that into a .ipk or .deb or .rpm distribution. It’s basically a tool for creating and distributing highly customized and botched-up Linux and doing many things which may look like GPL-violations but aren’t :wink:

tl’dr: Yocto/OE is targeting system integrators and firmware designers, not end users.