[BPI-R3] Mesh (802.11s) didn’t get it to work [SOLVED]

Good morning

I’m trying to use Mesh (802.11s) according to the tutorial between two BPI R3 -V1.1, but I didn’t get it to work. is it even possible? or am I doing something wrong?

config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/18000000.wmac'
option band '2g'
option cell_density '0'
option country 'BE'
option htmode 'HT20'
option channel '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wmac+1'
	option band '5g'
	option cell_density '0'
	option country 'BE'
	option channel '36'
	option htmode 'VHT20'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'openw'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'lanx'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'OpenWrt'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'lanx'

I found a bug using the method of scientific poke. If you create another mesh interface on either side, with exactly the same settings (the password may not match), then the mesh network works.

When creating mesh interfaces, scanning of wireless networks on the device does not work.

    config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wmac'
	option band '2g'
	option cell_density '0'
	option txpower '15'
	option country 'US'
	option htmode 'HE40'
	option channel '5'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wmac+1'
	option band '5g'
	option cell_density '0'
	option txpower '20'
	option channel '36'
	option htmode 'VHT40'
	option country 'US'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option encryption 'sae'
	option mode 'mesh'
	option mesh_id 'mymesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'LAN2'
	option key '987654321'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option encryption 'sae'
	option mode 'mesh'
	option mesh_id 'mymesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'LAN2'
	option key '123456789'

mesh1

1 Like

Problems were solved by forced change of mac address.