BPI-R3 loses connection after trying to download anything at max speed

Hello, I’ve been using BPI-R3 OpenWrt with WireGuard, PBR and AdGuardHome for a few months, besides a few hiccups here and there, no problem like this before. Whenever I try to download something with my VPN on, and it hits 80-100Mbps, after a few minutes the whole banana pi stops getting internet, ssh’ing into the router and running ping google.com results in a ‘bad address’. Downloading without the VPN on seems to work just fine, but it makes no sense to do this. I’ve tried:

  • Using another DNS Servers on AdGuardHome.
  • rebooting the bpi-r3 after this occurrence.
  • Redoing all my config since I think there was some stuff messed up, I’ve had this configuration backup from a few months now. Every time something breaks, and I need to burn a new image in my SD card, I used the same config.

My current setup is looking like this: ISP Router → BPI-R3 (ISP router connected to wan) → Dumb AP (BPI connected to a LAN port, using VLAN Tagging from my BPI). And the only ‘fix’ that seems to be working is turning off my ISP Router, and waiting a few minutes to turn it on again and reboot my BPI-R3. Even tho I’m not sure if this is fixing my connection, this is the only thing that worked.

I thought this could be something wrong with my ISP Router, but when connecting directly to a LAN Port and testing the connection, everything is fine, Wi-Fi is ok too. So, I’m not sure if there is some gimmick happening here, but I can’t really tell, and I’m not sure how to test it.

My CPU while using the VPN and downloading at max speed stays at ~60% with a thermal of around ~55-60C (using luci-app-statistics), and without VPN something like ~26% and couldn’t check the temp, since I’ve reinstalled my config the opkg update started failing after some time, and I can’t install it, I’ll update if I get the values.

If anyone thinks my config is necessary here, just tell me, and I’ll update the post with my /etc/config/*