Bpi-r3 i2c on gpio

Hy. I need to use i2c in GPIO to plug an ads1115.

For the sda i use the pin 3 and for the scl the pin 5 (below the first pin 3.3v)

I refered to the pinout gpio of the bananapi r2 ( didn’t find about r3).

But when i try to detect the address, i see nothing.

In the GPIO, it is the i2C(1) instead i2c0 for sfp, isn’t it?

Thank by adavance

Afair the i2c on gpio-header was i2c2,because i2c for sfp is found first

Just scan all available i2c busses with i2cdetect (maybe need -r switch)

1 Like

thanks to answer me :slight_smile:

I scan the i2c2 but no Traces about my ads1115.

i looked the dts of the r3 and didn’t see anything about i2C2, just i2c0. Can it come from it?

This is what i did

I have just got i2c working on the BPI-R3 I started with a RPPI Sensor Hat, and connected it via a 26pi extender when I ran i2cdetect only one of the 6 sensors where found. while on the RPI all where found I developed my application in C on the RPI. Then added the source it to my BPI-R3 image It worked. even though it was not detected - the only change I had to make was the i2c bus number on the RPI i uses bus 1, and on the BPI-R3 i used bus 0

hope this helps someone