BPI-R3 Can anyone share how to configure debian to work as a router?

It depends on the interface names…and on which interfaces you need the offloading

I guess eth1 when your sfp is there,but you can add all hardware interfaces you see in ip a

the same way as openwrt works…that’s not all interfaces ??

I do not know how openwrt do things,but hw offloading works with macs (eth0/eth1) and dsa interfaces (lanX,wan). Afaik no bridges or other (tun,…) can be bound to offloading driver

Have not done much with offloading as i have only 25mbit

root@bpi-r3:/etc/config# nft -f /etc/nftables.conf
/etc/nftables.conf:9:17-21: Error: syntax error, unexpected flags
                flags offload;


i think i’m going to send back this BPI-R3 to the reseller and buy a Mikrotik RB5009…

dev boards are definitly not for me…

Mhm, should be this module

So anything else is missing,maybe the vendor kernel does not yet contain r3 flow offload driver.

My debian image does not have it too. Current 6.1 should have it,but have not tried yet.

I have another guess…which debian version is the image you have? Afair nft in buster does not have the code for controlling the hw flow offload. I had sent a patch for it.



which nft version do you have? the change is in v0.9.9+

root@bpi-r3:/# nft -v
nftables v0.9.8 (E.D.S.)

so we have the rootcause why hw flow offload not works here…i have a newer nft selfcompiled somewhere in my gdrive…i look for it an put link here


take the r64 one and unpack it to root (/)

should be like this (replace the filename before)

sudo tar -xzf file.tar.gz -C /

you should uninstall nftables before else the new files can be overridden on update

i can’t connect with ssh to the BPI ?? the connection is refused, why ?

i uninstalled nftables from serial btw…

any way to send the file from serial ??

however i edited /etc/ssh/sshd_config with :

PermitRootLogin yes

root@bpi-r3:/etc/config# systemctl status ssh.service
● ssh.service - OpenBSD Secure Shell server
     Loaded: loaded (/lib/systemd/system/ssh.service; disabled; vendor preset: >
     Active: inactive (dead)
       Docs: man:sshd(8)

Afaik not…take card out and copy from pc to card.

Ssh needs completely setup network…this depends on the interfaces and subnet you use. I do not inow if zhis image already use systemd-networkd or the older ifupdown (/etc/network/interfaces)

i can do that ??? :thinking:

i can’t see the rootfs… i can’t do this from my PC

At least the boot-partition should be able to accessed from windows too if you do not have a linux host

that’s all the folders i can see :


so where to put the file ???

well that’s very too complicated for me, i give up.

Thanks for all your efforts !!!

it does not matter where you put the file…it has to be on card (just copy it to D:\ directly this will be /boot in the booted system) to have access to it from the booted r3…but netherless you have to setup your network at some time…

ok so i did this, and now ?

root@bpi-r3:/tmp# tar -xzf nftables_bpi-r64.tar.gz -C /

you have to point to the right location of the file…should be /boot/nftables_bpi-r64.tar.gz if you put it into D:\ directly

yes, i did it already, and moved the file in /tmp in which i executed the tar command

btw i can’t see where it is unpacked…