[BPI-R3] build of own openwrt image not booting fully

Building an image of openwrt seems to work to a point. Regardless if I build it locally or from the openwrt site.

Booting it, I see 3 mounted partitions, but no root or overlay. Is there any secret to get the image to bring them up on boot? Running mount_root just silently exits.

root@OpenWrt:/# df 
Filesystem           1K-blocks      Used Available Use% Mounted on 
tmpfs                  1020412     15520   1004892   2% /
tmpfs                  1020412        56   1020356   0% /tmp 
tmpfs                      512         0       512   0% /dev

This looks like the board booted into recovery/initramfs mode. This happens deliberately after kernel crashes if there are logs present in /sys/fs/pstore/ which you have clear using rm /sys/fs/pstore/* (and ideally also submit them here for further investigation).

Another reason can be that images above a size of ~ 20 MiB were brioken recently in OpenWrt. This has been fixed by

So make sure your build or snapshot is after this commit.

Always the same… shortly before I ask, the fix gets put in place…

I’d tried some snapshots all last week and even choosing the basic config always failed, but lo and behold, this mornings snapshot worked.

Now I can wait for kernel v6.3, openSUSE to release tumbleweed with it, then I can set about building it to run off nvme, with standard disclaimers.

Thanks Daniel.

And there were no entries in /sys/fs/pstore/.