[BPI-R3] Brand new Pi BPI-R3 - no output visible on the USB TTL console

Hello All,

I am a newbie around the new banana OpenWRT router, bought this one and wanted to make some fun. My last experience with OpenWRT was on Linksys WRT54G, so it was ages ago;)

I have bought the router, installed all of the antennas, placed the board into the case then interconnected the USB to TTL and wanted to start the configuration. Unfortunately besides of the red light on the PWR led and (if pins are set all UP - to run from SD Card) G led nothing is lighting up. Fan is running on for around 30 seconds and then stops.

I have bought 2 kind of USB to TTL as my initial idea was that the console connection is broken. Unfortunately using both consoles I have not seen any response from TTL. I have tried numerous of things, like setting different speed ports, tried all of the pin configurations and it does not make any difference. I used default parameters for connection - 8N1 (Data Bit - 8, Parity - None and Stop Bit set to 1). When I input a char from the keyboard I can see the Tx led lighted on the USB to TTL. I have also tried to swap the Txd with Rxd with no change.

I have been able to flash the SD card with the different images, but I would expect to have any output on the console.

Following guides have been used as a reference: https://wiki.banana-pi.org/Getting_Started_with_BPI-R3

How to Setup Banana Pi R3 with OpenWRT | by Flow | Medium.

Does anyone have any idea how to start a deeper troubleshooting as I am out of ideas at this point?

Thanks for any input from anyone!

115200 baud 8n1 is the correct setting,make sure ttl level is 3v3, and rx/tx crossed (rx on tx and tx on rx) and gnd connected too. Then you should see at least bootrom,also if image is not flashed correctly.

Which system xact uart adapters doe you have? To prevent wifi issues you should use ftdi or cp2104 (not cp2102)

I have given a try with CH340 - CH340G RS232 aktualizacja USB na TTL moduł konwertera UART Port szeregowy UFS-HWK STC Dowanloader programista szczotka Upgrade mały talerz - AliExpress and CH340G PL2303HX PL2303 USB do RS232 TTL konwerter moduł adaptera/USB TTL konwerter moduł UART CH340G CH340 moduł 3.3V 5V przełącznik - AliExpress

I am possibly mixing the names up here, please advise if those will or will not work and recommend any to buy any.


Ch340 are mostly 5v and may brick your board, profilic are known as unstable…as said above try to use ftdi or cp2104

Bought this one - Konwerter USB - UART TTL układ CP2104 Silabs (gotronik.pl)

Unfortunately the result is still the same, no output on the console.

How to ensure that the board was not bricked? Any way or I should with some more experienced electronics technician?

You have crossed rx/tx and connected gnd and using the right settings (115200 8n1)?

Where have you connected the uart? On the dedicated debug-pins (3pin header) or uart on the 26pol gpio header

One good test is to do a loopback. On the USB to TTL device. Use a jumper of something to short the TX to the RX pin, without plugging it into the BPI-R3. Run your serial comms program, minicom or whatever, and check that it is echoing back to the screen anything you type. If the USB to TTL device has tx/rx lights, you should see them both flashing. If you do not get the echo back, you need to adjust your serial comms program settings to disable things like hardware and software flow control, disable carrier detect, disable modem detect, that sort of thing. Until you get the echo back working. Get a volt meter and test the TX pin to ground, and check that it is 3V and not 5V. Then plug the RX and GND pins into the BPI-R3, switch the BPI-R3 on and you should see some output. The RX pin of the USB to TTL adapter connects to the TX pin of the BPI-R3. Once you get output, finally plug the TX pin in and you should have comms.