BPI-R3 1Gbps Wireless

Hello, New to the forum, and I was wondering, should the BPIR3 be able to have a gigabit wireless speed out of the box with the latest snapshot of OpenWRT? Testing on my cellphone and laptop, they both reach max speeds of 300Mbps Download and 200~ Upload, on my computer cable is doing fine 900~ download and 500~ upload. If needed, tell me what information I should display here to help you out.

Yes, it depends by the clients. My iPhone 13 reach about 830mbs but other 2x2 android and laptop devices with 160mhz bandwidth 1,7gbps. Try using 5ghz channel and to configure 160mhz channel bandwidth.

hmm, I tried earlier today changing my 5Ghz to 160mhz but when I did, it just disappears. Any idea on why?

Are your device WiFi 5 (AC) or WiFi 6 (AX) ? Anyway try to set WiFi channel on R3 to 36 and security to WPA2…

My laptop is AC (802.11ac), phone not sure, but I’m only testing on my laptop now.

I did some research and I did find that it needs to be a specific channel, so I changed it 100 from this post. The security is WPA2 only now (it was WPA2/WPA3 mixed) but it didn’t look like it changed much, on my laptop now it’s reaching 300mbps both down and upload. Screenshot%202023-04-21%20173107 Screenshot%202023-04-21%20173220

If your devices are WiFi AC better to set 80Mhz bandwidth (channel 36 in most case is better than channel 100). 160Mhz can be used only by WiFi 6 devices. Most probbaly your laptop only use WPA2 but if it works it is ok to use WPA2+WPA3 mixed mode.

Probably the maximum theorical connection speed you can reach with your laptop with 5Ghz radio in Wifi AC is 866Mbps or 433Mbs (depends on maker and model) and it can reach a real maximum speed of about 600Mbps or 300Mbps in ideal conditions at 1-3 meters distance with no obstacles. Some other factors can limit Wifi speed (distance, number of device connected, interference by other networks). So 300Mbs may be ok.

Have you tested your laptop with different router and better results? What is the maker and model of the laptop’s WiFi card?

Changed it to channel 36 and now it’s 80Mhz. Same result as b4.

Currently, only the laptop is connected to the Wi-Fi from the BPI-R3, and they are both practically side-to-side.

I did test out on my Archer A7, currently I’m using it as an AP for my R3, but previously the results were the same, around 200Mbps d/u (on the R3 Wi-Fi it’s better).

Running lshw -C network on the laptop it showed that the vendor Realtek (probably the maker too, correct me if I’m wrong) and the displayed product is ‘RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller’ (since I’m no expert, I may have found the wrong info, on the website that I bought it there was no extra info about it)

RTL8111/8168/8411 is the wired controller.

Anyway it seams that your download/upload speed is limited by your laptop and not by the R3. Maybe you can change the wireless adapter on your laptop to increase speed but compatibility need to be checked, for example with more recent Intel AX200 ngw or AX210 ngw, that costs about 20/25€. But it is really important that you check the compatibility with your laptop (ie. mini PCIe adapter vs M.2 PCIe adapter and so on) to avoid to waste money. Note: avoid Intel AX201 or AX211 that need specific recent Intel CPUs to works.

welp, I’ve must have been half sleep yesterday because when listing the devices with that command it literally says what they are exactly,

   description: Wireless interface
   product: Wi-Fi 6 AX201
   vendor: Intel Corporation
   physical id: 14.3
   bus info: pci@0000:00:14.3
   logical name: wlo1
   version: 20
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=5.19.0-40-generic firmware=72.daa05125.0 QuZ-a0-jf-b0-72.u ip=192.168.1.118 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: iomemory:600-5ff irq:16 memory:6001144000-6001147fff

Accord by this log it should be this, but it doesn’t match the laptop vendor website, anyway this is a brand-new laptop, it feels weird even thinking it cannot push anything more than 300mbps.

Ok, with this adapter you should double the speed at least (my laptop with AX200 adapter reach 1700Mbps with a 2,5gbps FTTH internet connection)

Have you made a test with Windows 10/11 and updated drivers?

I did not, the only computer that I have with windows is cable only, my laptop is using Linux.

I could try to set up a dual boot on my laptop if you really think this could be the reason, but this would be weird since my laptop and cellphone are reaching pretty similar speeds.

Maybe the “low” speed it is related to linux driver but it is only a guess. What are tx-rx connection rate showed on the R3 Network-Wireless menu?
Lets try with the smartphone… what model?

My phone is a Samsung M62, taking from this guy here it’s AC, so no problem with a gigabit connection in theory.

This is while the phone is doing a speedtest (sometimes the 433Mbit/s just disappears):

image

And this is after:

image

@Sandokan for the speeds that you said that you are getting above, 1700Mbps, are you using the ‘stock’ antennas that come with the package bought from AliExpress or did you buy a different one? Because so far, it’s really weird, it should be working fine, but it’s not. I don’t even know if the antennas only can make such a difference on the Wi-Fi speed, since they are close it should work just fine, right?

I own a Samsung A52s 5g with WiFi 5. It link at 600Mbps, real download speed about 500mbps . I also tested a Xiomi Mi Mix 2 with WiFi 5 and it link at 866Mbps, real speed about 600mps The iPhone 13 is WiFi 6 and link 1200Mbps with a real speed of about 800Mbps

I know that A52 4g link at 433Mbps so maybe it is the same for the M62. In this case 300Mbs real download speed seems ok.

It remains to be understood why your laptops with AX201 go at the same speed but as mentioned it could be a linux/driver related problem.

Really strange, but honestly, I don’t think I should spend any more time on this. I really wanted to max out this router, but even though it doesn’t push anything faster than 300Mbps even under 10% load, it’s still good.

One thing I noticed is that when I tested my ISP Router earlier today with default settings/firmware, the output was the same, 300 Mbps down/up. I’m not sure if my ISP is throttling my Wi-Fi connection in some way (or even if this is even possible), I suppose I’ll have to be ok with this. Many thanks for your time.

One way to test the real WiFi speed is to install and config an iPerf 3 server on your laptop and wire connect it to the R3. So you can install an iPerf 3 app on the smartphone e check the real Wifi speed avoiding internet connection limitations. The only limit is the speed of your 1Gbps wired connection.

The ISP cannot change the WiFi speed of your R3. I know that some ISP ONU/router have logics to “optimize” the Wifi network.

You can reduce load on R3 enabling Packet Steering, Software flow offloading and then Hardware flow offloading. Also you can try to enable WED for hardware offloading of wireless download.

In my opinion: your phone is limited by hw your laptop is limited by linux driver

I had similar issue with an intel ax200 card on ubuntu, I fixed disabling power save mode in “/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf” change 3 to 2.

[connection]
wifi.powersave = 2

Maybe, on Windows 10/11 systems the AX200/AX210 power saving is disabled by default.

Unfortunately, it did not work, same results as b4.

I did this, after running iperf3 -s -D && iperf3 -c 127.0.0.1 all transfer values were between 700-750MBytes. So maybe it’s something with the Linux driver, the only for me to find out would be to test the same system on Windows, which I’ll do later this week after I set up dual boot.

I’ll try to toggle these options brb