BPI-R2 won't boot


I got my B-PI R2 yesterday and it’s fighting very hard to stay unusable. I’ve followed the instructions some of you guys posted here BPI-R2 boot / power suppy but without any success.

My SD-Cards that I used seems to be ok (tried FreeBSD, Ubuntu, Debian), neither dd nor win32imager reported any error while writing to them, the power supplies I used (2A+3A) are also ok and used on a daily basis without any problems.

The B-PIR2 lights up it’s three LEDs when pressing the power-on button, but the system doesn’t boot up and my screen stays black.

Am I doing something terribly wrong to keep the B-PI from booting up ? (or is my device broken ?)

Hi you must press min 10 sec the power button


I did that, 4secs, 10 secs, up to half a minute…

Didn’t work either :frowning:

What SD card do you have? Have you ever before formated the SD card? (SDFormatter) https://forum-bpi.de/viewtopic.php?f=9&t=167

I’ve this card: https://www.reichelt.at/SD-Karten-Micro-/INTENSO-3413470/3/index.html?ACTION=3&GROUPID=4802&ARTICLE=126587

Sure, I formatted the card before using dd/win32writer.

Wolfgang, do you know if there are other bootsequences I can use, like from USB or something like PXE/BOOTP (just to filter out if the SD-Card-Reader is broken)

Thanks for your time =).

Ohne SD-Karte kann man es nicht booten soweit ich weiß ich habe das Bord nicht. Du brauchst ein Boot medium das du auf den Nand schreiben Kannst.

I’m visiting you in the german forum…is besser =)

@Shaggy Danke ist leichter

Have you looked in boot-log (serial console)?

Which german forum (forum-bpi.de?)? Please make link to crosspost and report here also if Problem solved


You can connect usb otg port to pc so that you don’t need to press the power button.

No haven’t take a look at that, which raised my question how do I get this log ? (is this right ? http://docs.cubieboard.org/tutorials/ct1/development/booting_from_usb_otg_port )

Yes is the forum-bpi.de, I have opened a thread there.


There you see pins for debug-uart. Connect a usb2serial-adapter (tx to rx) and use on connected pc an application like minicom (linux).

Maybe you get an error the like sdcard not found or did not found boot-partition

Thanks Frank, I’ll do that - I’ve ordered the cable and come back here when I have the logfiles from the boot.

Hi FrankI

I got the cable today and I failed to get it running :(.

The pictures shows how I’ve connected the TTL Cable with the BPI (white RX into USB port, and green TX out of the USB port).

The USB device itself was recognized by the kernel (I’m on Debian Testing):

Sep 12 15:15:42 springfield kernel: usb 1-1: new full-speed USB device number 2 using xhci_hcd
Sep 12 15:15:42 springfield kernel: usb 1-1: New USB device found, idVendor=10c4, idProduct=ea60
Sep 12 15:15:42 springfield kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Sep 12 15:15:42 springfield kernel: usb 1-1: Product: CP2102 USB to UART Bridge Controller
Sep 12 15:15:42 springfield kernel: usb 1-1: Manufacturer: Silicon Labs
Sep 12 15:15:42 springfield kernel: usb 1-1: SerialNumber: 0001
Sep 12 15:15:42 springfield kernel: usb 1-1: cp210x converter now attached to ttyUSB0

I started minicom with the one obvious option … minicom -D /dev/ttyUSB0 but I didn’t receive anything…

Can you help me again please ?

sudo minicom -s

Change here port = ttyUSB0, baud 115200 8n1 Flowcontrols both no

Save config and start minicom as user. now start your bpi-r2

You use gpio-connector? console is a separate pin-bar

debug uart is here and baud rate is 115200 :slight_smile:

1 Like

I’ve added myself to the dialout group, which the usb belongs to, to avoid the sudo.

Ahh I see my fail - I connected it to the GPIO, not the debug uart… omg I’m sorry for my stupidity…

I’ll try again. …

Ok I connected it on the debug-UART, RX into-USB is white.

and this the statusline minicom shows me at the bottom:

CTRL-A Z for help | 115200 8N1 | NOR | Minicom 2.7.1 | VT102 | Offline | ttyUSB0

Minicom shows no response at all, I tried cutecom too, which showed me a 16:55:23:851] <break>

from time to time, but there is nothing “human-readable” at all.

Again, thanks alot guys for your help…Appreciate it very much.

Dont forget gnd! and try swapping rx/tx (dont know colors). Rx->tx,tx->rx