Bpi-r2 stuck on reboot with ubuntu 20.04

Hello, I have installed Ubuntu 20.04 in my bpi-r2 , I have a problem, if I restart or shutdown my board, I ping my bpi-r2 and the ping never stop, ping still active, I need restart with the reset switch on board.

This is my dmesg

Untitled Document 1 (77.5 KB)

This is my /var/log/syslog

syslog (135.2 KB)

Thanks in advance

How have you created ubuntu 20.4 image? Afaik there is no such image public. Hostname looks like bpi…is it an upgraded 18.04 (or older)?

Which kernel do you use? It looks like 4.4.x because there is a eth1 visible

Hi, I download Ubuntu mate 16.04 and upgrade to 18.04 and 18.04 to 20.04 with kernel 4.4.70-BPI-R2 I use this command

sudo do-release-upgrade

Best way is always install a fresh system instead of upgrading,but you can try upgrading my 18.4 which also has a newer kernel. As i tried official images i noticed some bugs while running (don’t remember if it was debian or ubuntu) so i created clean minimal images for debian stretch/buster/bullseye and ubuntu 18.04…not created a 20.4,but wrote steps down in my wiki…

Basicly bootstrap an ubuntu 20.04,backup /lib/modules from image, delete all from root partition (do not touch bpi-boot),copy bpotstrapped rootf and copy back /lib modules. Then proceed with steps i’ve wrote down in wiki. At least change root-pw and add apt sources.

I have try this and works fine

https://www.armbian.com/bananapi-r2/

It’s ok,so issue solved? I guess armbian kernel does not support r2 internal wifi,but if you don’t need it you can use it. Maybe you can replace kernel with mine to have the mt6625 driver