BPI-R2 PRO ENABLE OTHER Serial Interfaces

Hello BPI Team, I have a BPI R2 PRO . I have tried to upload emmc flash file but there was something going wrong and i upload to SD card image which is in this link


to my devices EMMC. It works now. When run “dmesg | grep tty” command , I see only ttyS3, Is there any way open other ttyS interfaces.
Bes Reagrds.

If you use my kernel,you can enable others in dts,have noticed position (pins) and conflicting devices (which have to be disabled) there.

Thanks you for your answer , Now should I build this https://github.com/frank-w/barebox-r2pro project? Or there was another repo there? Could you hel me? Best Regards

barebox is alternate bootloader (to replace uboot).

just use my BPI-R2-4.14 repo which also contains kernelsource for r2pro up to 6.0-rc. 5.19-main contains the last stable version, just change in build.conf to r2pro and running ./build.sh with param importconfig, then dts (to open the boards dts), then config (to change anything in your config if needed) and then without param to build

with dts-param you should see this file: https://github.com/frank-w/BPI-R2-4.14/blob/5.19-main/arch/arm64/boot/dts/rockchip/rk3568-bpi-r2-pro.dts#L649 and you can set status to okay (from disabled)

Thanks for your reply. I will do it. I have last question. After build can i take image for SD card just like banana pi r2 or is this require another process.

kernel supports both, but it requires a rootfs after kernel is loaded…you can first try with an initrd (busybox or similar) and then create an own rootfs with linux you want (debian,ubuntu,archlinux,…). or simply use one of my images and replace kernel/fdt only (in your case i guess fdt replace is enough)

only bootheaders are different and config in rootfs…

Thank you for your eply vut i did not understand. Now I build your sd image for debian 10 with Rockchip Create Upgrade Disk Tool program. After this, i see boot,bin,dev folders. where should i paste kernel folder . Could you help me about that? Best Regards

Flash my debian to disk,compile kernel on your host system and copy arch/arm64/boot/Image.gz and arch/arm64/boot/dts/rockchip/rk3568-bpi-r2pro.dtb to the boot partition in extlinux folder and change config to match filenames

Thank you for your reply but i am sory i do not understand. Now i have folders in my SD card which are produced by Rockchip Upgrade tool . Other side i build your repo and extract BPI-BOOT and BPI-ROOT another folder. I found files you mantioned above. Bu i do not under stand how i can paste this file in my sd card

i have not used rockchip tool yet so i do not know the structure it produces…basicly you neee to find the kernel loaded in your image and replace it by my one. but there can be problems if you try to load mainline kernel with downstream uboot/atf. so i suggest using a actual bootchain like in my images to load actual kernel

I tried for many times but i did not work. Is there another way to build and create an image just like this :https://drive.google.com/file/d/1QMkFW8PU7DDocrDOwOETy1YU3yDZZNNA/view?usp=sharing

can I change pins uart in https://github.com/BPI-SINOVOIP/BPI-R2PRO-BSP-5.10.x/blob/main/kernel/arch/arm64/boot/dts/rockchip/rk3568.dtsi and follow instructions in here: https://github.com/BPI-SINOVOIP/BPI-R2PRO-BSP-5.10.x/tree/main/debian ? Is there any possibility for this?

You tried my images? Make sure you press maskrom button on first boot directly on poweron. Else board will boot from broken emmc and got stuck.

When you booted successfully from sdcard (you see it in uboot version…my version is 2021/22 and downstream is 2017 or 2019). Boot linux without pressing the button. This will cause emmc is found by linux and will let you erase the first 10M of it. After that boot from sd works without problems

of course you can try to add missing defs to the BSP-repo…but then not into the SOC-level devicetree…use the board-level dts

I upload this https://drive.google.com/drive/u/0/folders/1ff7ttUhdqodgpOmQQXmzyeM0Q0Sphjl0 to SD card i boot my BPI R2 PRO succesfully. after that I build this repo in my computer :https://github.com/frank-w/BPI-R2-4.14/tree/5.19-main repo Screenshot%20from%202022-09-28%2015-01-30 After that select “1 pack” Screenshot%20from%202022-09-28%2015-04-48 And It creates BPI-BOOT BPI -ROOT Files Screenshot%20from%202022-09-28%2015-18-03 Screenshot%20from%202022-09-28%2015-18-37 Screenshot%20from%202022-09-28%2015-19-00 Screenshot%20from%202022-09-28%2015-20-02 Now could you tell me what should I do ? Best Regards

as i said above, you need to replace dtb (and maybe Image.gz) from your current working image with the one in the Package (BPI_BOOT/extlinux)

Hello My sd card flies which works on banana pi r2 pro includes these files . I there is no etxlinux Could you tell me where should i repleace file Screenshot%20from%202022-09-28%2016-17-40

this is rootfs partition, kernel+fdt are on boot-partition

Downstream uboot maybe does not use distroboot so extlinux folder may be missing.

Hello I found boot partition location now. There are uboot misc,recovery,backup parts too. Could you tell me how can i modify this partition, i am new at ubuntu. Screenshot%20from%202022-09-29%2014-36-33 Screenshot%20from%202022-09-29%2014-37-46 Best regards

Hello could you recommend another program for burning image to sd card ? Rockchip tool create different partitions .

My images have simple fat boot partition with kernel/fdt files. It can be flashed with linux dd or any other image writing app

You have to do only the emmc erase at first time as my uboot is mainline and is not compatible with downstream version which seems to have parts already on emmc