BPI R2 - Openwrt internet not working

Hello, I bought a Banana Pi R2 and installed OpenWRT. I have tried several versions, but I have the same problem with all of them. My internet is down. The problem is with the WAN port. It won’t ping or update on Openwrt. I always get a connection error.

I have tried setting up the WAN as a static IP and DHCP client, but unfortunately it still doesn’t work. I have it connected behind the Asus router, but it doesn’t work behind the ISP router either. Where is the problem? info rozhrani ping

Without knowing your full network topology it is hard to tell a solution.

Have you tried ping from the R2? For ping after R2 you will need a static route on your main router or do masquerade (nat) on wan-port. Make sure wan and lan are in different subnets.

My sit is: ISP ROUTER (DHCP server) - (DHCP client) Asus router RT-AC52U B1 (DHCP server) - (DHCP client) BPI R2

I would like to put the BPI R2 in place of the Asus router.

So I tried again with the latest firmware and now the internet works if I connect the BPI R2 instead of the Asus router behind the ISP router.

But what could be wrong with the setup that my internet doesn’t work if I connect the BPI R2 behind the Asus router?

I guess because you use same lan-subnet on r2 and your asus and your isp router already knows it. Every router instance need to know each subnet connected over it. If you cascade all 3 routers, all segments have to use different subnets and all routers need to know them. E.g. if you have all 3 cascaded, your isp router needs to know if r2 and asus lan-segment is available over the asus Router and asus router needs to know r2 lan is reachable over r2 wan-ip

And before trying public internet,use private ips. Ping from r2 lan to r2 wan,then asus lan,asus wan and isp lan. If all these work your outing works so far and you can try public ip like If this works and “internet” not maybe you have name resolution issue…try to ping www.google.com and look if you see its ip address.

Thank you very much. I would like to ask how to upload openwrt from sd card to emmc? Can I use this instruction? BPI-R2 new image : ubuntu 16.04 V1.2.1 BT and WIFI AP mode are working fine 2017-11-27

If I understand correctly, I need to connect to BPI R2 UART to RX and TX converter and write those commands to the console?

Uart: https://www.aliexpress.com/item/1005001666154264.html?spm=a2g0o.productlist.main.13.1df9679bbKN2lK&dp=f651e63149004ec194d0e6f8abb2c23a&af=2032172&cv=47843&afref=https%3A%2F%2Fwww.akcedeals.eu%2F&mall_affr=pr3&utm_source=admitad&utm_medium=cpa&utm_campaign=2032172&utm_content=47843&dp=f651e63149004ec194d0e6f8abb2c23a&af=2032172&cv=47843&afref=https%3A%2F%2Fwww.akcedeals.eu%2F&mall_affr=pr3&utm_source=admitad&utm_medium=cpa&utm_campaign=2032172&utm_content=47843&aff_fcid=698a23e39b3a4044b7fd3ccfe024272b-1692025824483-09541-_ePNSNV&aff_fsk=_ePNSNV&aff_platform=portals-tool&sk=_ePNSNV&aff_trace_key=698a23e39b3a4044b7fd3ccfe024272b-1692025824483-09541-_ePNSNV&terminal_id=222fcdfae27c4c4cad7175e973dfe775&afSmartRedirect=y

You can also write it when booting from sdcard through ssh, but debug-uart is very useful if boot stops at some point.

Emmc needs different preloader and some modifications to uboot and linux to start from emmc and not sdcard again

I have written down some steps here:


But i cannot tell openwrt way if this is different…maybe there is an “install to emmc” option in uboot menu,which you see only with debug-uart

Just open debug-uart and in the data menu the option to upload openwrt to emmc and you were done.

I’ve already worked my way through setting up Openwrt and using SSH, but I discovered another problem. Why after installing OpenWRT is there still 7,1Gb of free memory left out of 8Gb? This is very little for some packages. Is there any functional instruction how to use the full memory capacity?

I have tried various instructions, the memory expands, but after a reboot the memory disappears again.

https://oopflow.medium.com/how-to-setup-banana-pi-r3-with-openwrt-d958514b47a5 https://www.wanuse.com/2023/01/openwrt-lede-vps-overlay.html

Afaik the best way is to create additional partition as extending rootfs will cause problems on sysupgrade…daniel wrote some tutorials for handling additional space in openwrt.

They are for r3,but it should be same for r2

I have studied all the instructions, but to no avail. It’s different from BPI R3, because with R2 I can’t push data to NAND memory. I can only load the OS from SD card or EMMC memory.

Every time I try to expand the memory, I succeed, but after reboot the memory disappears again.

After a clean installation of OpenWRT: pred2 pred1

After adding memory: Po3 Po2 Po1

After reboot: Reb22 Reb1