BPI-R2 no interfaces after uninstall wpa_supplicant

For some tests I performed the following commands:

apt-get remove wpasupplicant && apt-get install hostapd dnsmasq

Now I tried to reinstall wpasupplicant, but I don’t have access to any interfaces. grafik

How can I access them? They are not gone. ifconfig -a prints: grafik

hello,try “ifconfig ethx up”

This works only temporarily. And the BPI-R2 gets also no IP address. I found an issue, that the service of wpa_supplicant does not automagically start. But I fixed it with: systemctl enable wpa_supplicant.service

if you want the interfaces you have to configure them…in debian/ubuntu via /etc/network/interfaces

here you can define which port have static IP/DHCP/subnet/gateway…

Ty Frank :slight_smile: This configuration works for me.

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto wlan0
iface wlan0 inet dhcp
        wpa-ssid        SSID
        wpa-psk         PSK

But the system start takes about 5 minutes and I have an interface called eth1:avahi

One think, that i don’t understand is, why the interfaces work with the ubuntu stock image without any configurations in /etc/network/interfaces

Oh, before I forget it. I thought the BPI-R2 has gigabit ethernet. However, my Fritzbox shows me the following:



allow-hotplug lan3

Instead of

auto lan3

for the dhcp-interfaces

See http://www.fw-web.de/dokuwiki/doku.php?id=en/bpi-r2/network/start#dhcp for more infos