BPI-R2 New image : Openwrt/LEDE 2017-09-08

Hello Gary I finally succeed in downloading and installing the files. Now my BPI R2 is up and running, and the settings are persistent. Thanks a lot for your help, i will now try to configure my router correctly. I need to learn everything about LEDE. Have a nice weekend. Regards

Hay great work but I’m having a real problem trying to get the download as I only speak English I have tried everything but I still can’t get it please help

Can’t download as I only speak English and I have pressed every button but still don’t understand the download site :frowning:

why not just downloading the compiled image i’ve uploaded?

i have compiled that repo and uploaded image here:


  • mtk-bpi-r2-SD.img
  • mtk-bpi-r2-EMMC.img
  • lede.img.md5
1 Like

@frank-w, Can you confirm that the WiFi chipset can be used as a access point with this image.

Also, if you are going to provide images for this device. Could you include instructions on how to implement these images into the BPI-R2 (especially seeing that there is still an ad-hoc approach when providing sufficent guides within this forum).

Whilst installing and running these images via a sd / tf card is fairly straightforward, however there is still a lot of confusion within this forum about copying and running the image directly from EMMC.

I have not tested it by myself yet. But ap-driver is included and i have used that in 4.14 where it works (except 2 bugs)

1 Like

@frank-w I downloaded your compiled images and installed them to my R2. Now, I want to install a webinterface, luci for example, but I cant. opkg says " unknown package ‘luci’ ". Are there other download sources I have to use? And how I can use wifi and wifi ap?

i have only compiled the sources to make it available outside baidu…i have not tested the image and do not know anything about lede itself

maybe you have to setup the installer-system (package sources or similar)

@RW2003 Should this image work with HDMI? I have tried SD card with mtk-bpi-r2-SD.img image, and R2 seems to start and doing something, as I can see by looking at leds. But HDMI-connected display shows nothing other than just blinking

Hi Peter

The HDMI doesn’t work if you’re using LEDE image.

Thanks Gary

HDMI is not working. You can see and use terminal when you’re using the debugging uart port/pins.

Thank you. I guess I should buy a UART-adapter. Did you solve the issue with package source?

you can access bpi-r2 via ssh on over LAN-Ports, maybe http(s)-interface is accessable via this ip too

Yes. I thought about it. But this will happen only if everything will work without unexpected problems. And even if it will work by default I will certainly break network doing experiments with interface confuration and firewall :slight_smile: Anyway, thank you

for this case you’ll need http://wiki.fw-web.de/doku.php?id=en/bpi-r2/debug-uart till hdmi is working (not working in 4.14 yet)

no, I didn’t. But I didn’t try it again… I dont know how to fix it. In other version (self compiled images for example) it works…

It works with R2 and LEDE? Which images?

Hdmi works only with kernel 4.4 (default in ubuntu-images),lede uses 4.9

sorry, I mean the luci package works; not HDMI.

Hi, i have problem with opkg. I am not able to doeload any packages (luci, etc…) console says: “[package] has no valid architecture, ignoring” Is there some advice for me how to download and install packages?