[BPI-R2] minicom setup

Hi, So I have been trying to get my Banana Pi R2 to show something on my minicom screen for the past couple of months whether it be post messages or an OS boot-up screen. I have tried using the Ubuntu image (BPI-R2 Ubuntu 16.04 Kernel4.4 V1.3 ) and the centOS 7 (BPI-R2 Centos 7 Kernel4.4 20180112) that were provided on the Banana Pi R2 wiki page and nothing is displaying. Am I missing a step on the setup on the board or the minicom screen?

my settings for minicom are Serial Port: /dev/ttyUSB0 Bps/par/bits: 115200 8N1 HW flowcontrol: off SW flowcontrol: off

this is my output when I use dmesg | grep tty [ 0.390436] printk: console [tty0] enabled [ 1.232986] 0000:00:16.3: ttyS4 at I/O 0x50b0 (irq = 19, base_baud = 115200) is a 16550A [ 1036.566867] usb 1-1.1: ch341-uart converter now attached to ttyUSB0

any help is much appreciated thanks!

Have you pressed powerbutton long enough? Bpi-r2 needs ~10 seconds to start booting

Yes I have, both the green and red indicator lights stay on after I let go of the power button after 10 secs.

Is uart connected right (tx on rx,rx on tx,gnd)? Which vendor is your adapter?

Have you checked my wiki?


At least you should see output till “starting kernel”…after that it depands on right cmdline/dts

Yes! I have seen your guide for the UART setup, it is where I got the settings for minicom. The adapter, I am not sure which vendor it is but it came with the kit I purchased the board of amazon (when I checked with dmesg it came up as just USB Serial as a name and there are no markings on the adapter to indicate a vendor name). I tried reseating the connector plugs and I started getting some post hex codes during the power/boot up sequence but after that it just stops there. I tried pushing ENTER key to see if something happens after that but nothing of the sort. It just reposts the post hex code line from the start-up/boot process not sure how to interpret if it means there is something wrong with my settings or not.

Here is the attached image from the mincom console of my current situation

but you use the debug-uart-connector right (not uart from gpio-header)?

the usb-port is on your client? what does this say about vendor (lsusb -vv)?

i guess it’s some case of incompatibility/non-stable clock of usb2uart adapter

Oh yes, I forgot to mention I am connected to the debug art connector. After executing lsusb -vv, it says the vendor for the adapter is QinHeng Electronics and the product id is HL-340 USB-Serial adapter.

mhm, i don’t know this vendor…my adapters are all cp21x2, maybe you try with such. i guess it’s the adapter

So I have an usb adapter that is from this vendor and product id. ( idVendor: Silicon Labs idProduct CP210x UART Bridge). I tried using this one with the board and minicom is still having the same issue as previously stated where during the booting process and when I try to press any key after the board is fully powered and running it only shows hex codes.

Make sure you have not set -H option in minicom

**-H, --displayhex**

Turn on output in hex mode.

Normally mincom shows weired chars, not hex, on adapter problems/missing gnd/speed-problems.

You can call minicom binary directly (/usr/bin/minicom),but it will still use saved config

Ahh, that solved the problem with my minicom setup. I did not know that the display hex option was a problem. Thank you fo the help!