BPI-R2 image: OpenMPTCProuter 0.55b2 Kernel 5.4.35

The only openwrt release can boot from sd-card that I can find. mptcp must be disable to use as a common router.

https://www.openmptcprouter.com/release/develop/5.4/bpi-r2/targets/mediatek/mt7623/

PCI-e module for WiFi:

2 Likes

great to hear it

I have two problems:

first I set WAN1 to dhcp and I can browse internet through LAN cable connection, but I cannot do opkg update on router, seems no internet on router,

and second:

do my WLAN card will work? it’s similar to your, Sparklan WPEA-352ACN - Qualcomm Atheros QCA9880-BR4A chipset (probably have to use ath10k driver which needs to be installed by opkg)

seems internet is working on the router, but I cannot fetch some updates:

[email protected]:~# opkg update

Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/luci/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_luci Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/luci/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/packages/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_packages Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/packages/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/base/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_base Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/base/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/routing/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_routing Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/routing/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/telephony/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_telephony Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/telephony/Packages.sig Signature check passed. Downloading http://openmptcprouter.com:80/release/5.4/targets/mediatek/mt7623/packages/Packages.gz *** Failed to download the package list from http://openmptcprouter.com:80/release/5.4/targets/mediatek/mt7623/packages/Packages.gz

Downloading http://openmptcprouter.com:80/release/5.4/packages/arm_cortex-a7_neon-vfpv4/base/Packages.gz *** Failed to download the package list from http://openmptcprouter.com:80/release/5.4/packages/arm_cortex-a7_neon-vfpv4/base/Packages.gz

Downloading http://openmptcprouter.com:80/release/5.4/packages/arm_cortex-a7_neon-vfpv4/luci/Packages.gz *** Failed to download the package list from http://openmptcprouter.com:80/release/5.4/packages/arm_cortex-a7_neon-vfpv4/luci/Packages.gz

Downloading http://openmptcprouter.com:80/release/5.4/packages/arm_cortex-a7_neon-vfpv4/openmptcprouter/Packages.gz *** Failed to download the package list from http://openmptcprouter.com:80/release/5.4/packages/arm_cortex-a7_neon-vfpv4/openmptcprouter/Packages.gz

Downloading http://openmptcprouter.com:80/release/5.4/packages/arm_cortex-a7_neon-vfpv4/packages/Packages.gz *** Failed to download the package list from http://openmptcprouter.com:80/release/5.4/packages/arm_cortex-a7_neon-vfpv4/packages/Packages.gz

Collected errors:

Wget error code 8 is defined as server error…

https://www.gnu.org/software/wget/manual/html_node/Exit-Status.html

I guess package you try to fetch does not exist…try downloading manually. Maybe ping server address, try wget on top domain (get index page).

you’re right - those packages don’t exist on server (probably build was some kind minimal)

@hsdpa

Is it safe to install ath10k from openwrt repository?

opkg update and then opkg install xxx

You can modify /etc/opkg/distfeeds.conf like this:

src/gz openmptcprouter_core http://openmptcprouter.com:80/release/develop/5.4/bpi-r2/targets/mediatek/mt7623/packages

src/gz openmptcprouter_base http://openmptcprouter.com:80/release/develop/5.4/bpi-r2/packages/arm_cortex-a7_neon-vfpv4/base

src/gz openmptcprouter_luci http://openmptcprouter.com:80/release/develop/5.4/bpi-r2/packages/arm_cortex-a7_neon-vfpv4/luci

src/gz openmptcprouter_openmptcprouter http://openmptcprouter.com:80/release/develop/5.4/bpi-r2/packages/arm_cortex-a7_neon-vfpv4/openmptcprouter

src/gz openmptcprouter_packages http://openmptcprouter.com:80/release/develop/5.4/bpi-r2/packages/arm_cortex-a7_neon-vfpv4/packages

I installed kmod-ath10k from openmptcprouter.com, distfeeds.conf need to be modified.

I installed:

ath10k-firmware-qca988x

kmod-ath10k

and I can see wlan0 card in console when I run “ip a”

but there’s no “wireless” tab in Luci GUI.

Do you know how to install it? (which package/s)

Sorry tu disturb, after restart I can see wireless tab in Luci

and wifi is working perfectly on both Sparklan WPEA-352ACN - Qualcomm Atheros QCA9880-BR4A and USB 2.0 Asus USB-N14 - Ralink RT5372

1 Like

@hsdpa

Are you the person which can I tell bug I found?

I have low ethernet speed (between WAN and LAN) - few KB/s

Between WAN and WLAN1 or WLAN2 is perfect.

What to check?

(i did not try tu put image from yesterday:

openmptcprouter-v0.55beta4-r0+13235-eb17ee294c-mediatek-mt7623-bpi_bananapi-r2-ext4-sdcard)

You can check if you have trgmii active on gmac 1, gmac2 is not available on default (and mine 5.4)…and look if trgmii-patches are in:

https://patchwork.kernel.org/project/linux-mediatek/list/?series=266293

i’m using ready to use build (not compiling by myself). Can you tell me how exactly to do it?

(besides that everything is OK in this build - except that, i have faster wifi than lan)

I made iperf3 test between bpir2 and bananapipro on lan and I can see retries:

[email protected]:~$ sudo iperf3 -c 192.168.1.1
Connecting to host 192.168.1.1, port 5201
[  5] local 192.168.1.21 port 48602 connected to 192.168.1.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  15.4 MBytes   129 Mbits/sec    4    276 KBytes
[  5]   1.00-2.00   sec  15.7 MBytes   131 Mbits/sec    0    314 KBytes
[  5]   2.00-3.00   sec  15.4 MBytes   129 Mbits/sec    0    348 KBytes
[  5]   3.00-4.00   sec  17.2 MBytes   144 Mbits/sec   29    273 KBytes
[  5]   4.00-5.00   sec  20.9 MBytes   175 Mbits/sec    0    325 KBytes
[  5]   5.00-6.00   sec  22.2 MBytes   186 Mbits/sec   13    260 KBytes
[  5]   6.00-7.00   sec  16.4 MBytes   138 Mbits/sec    0    307 KBytes
[  5]   7.00-8.00   sec  22.4 MBytes   188 Mbits/sec    0    359 KBytes
[  5]   8.00-9.00   sec  21.0 MBytes   176 Mbits/sec    0    399 KBytes
[  5]   9.00-10.00  sec  20.8 MBytes   174 Mbits/sec    0    437 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   187 MBytes   157 Mbits/sec   46             sender
[  5]   0.00-10.02  sec   187 MBytes   156 Mbits/sec                  receiver

I exchanged lan cable. Between other devices network work fast as hell, except as that goes through router (openmptcprouter - banana pi r2)

For checking patches you need sourcecode…trgmii can be checked by sysfs

SOC-side:

cat /sys/firmware/devicetree/base/ethernet\@1b100000/mac\@0/phy-mode

and switch-side:

cat /sys/firmware/devicetree/base/ethernet\@1b100000/mdio-bus/switch\@0/ports/port\@6/phy-mode
[email protected]:~# cat 
/sys/firmware/devicetree/base/[email protected]/[email protected]/phy-mode
[email protected]:~#

[email protected]:~# cat 
/sys/firmware/devicetree/base/[email protected]/mdio-bus/[email protected]
f/ports/[email protected]/phy-mode
[email protected]:~#

seems both are empty

No it’s trgmii without linebreak (before username root in your prompt). But we need info that the 2 Patches above are in fixing trgmii issues. Maybe you can replace kernel with one of mine for testing?

I missed that.

Kernel - if it’s already compiled - yes

If not the procedure is the same as in linux to compile?

but at first I will upgrade beta3 to beta4 this evening - and then if it does not help I will repleace the kernel (the procedure is the same as on linux?)

I don’t know how in your image kernel is loaded.

My 5.4-main contains these patches, https://github.com/frank-w/BPI-R2-4.14/commit/0cb5221062b693463d1725bc6c3ef124b012c741 and this https://github.com/frank-w/BPI-R2-4.14/commit/1ff0732cf8055131050fa0c26c49429d6e725505

Compiled kernel is on github releases

I’m also experiencing a slowness issue on OpenWRT using latest 5.4.39 kernel. I have the OpenWRT fork https://github.com/cioby23/openwrt using patches gathered by @smaller09 and using kernel 5.4.31 released over one month ago which works fine without issues.

Recently I tried again to apply the same patches on the latest trunk, it compiled successfully but I can barely load a web page and it times out. I guess something has changed between kernel releases 5.4.31 and 5.4.39.

I do not see any errors only slowness when my PC is connected on the LAN ports of the BPI-R2