BPI-R2 FreeBSD support/ZRouter.org support

I have all kernel-versions starting from 4.14 in that repo till 5.3 which is not yet released…

Also 4.19+ for r64

1 Like

Yes I was going through your r2 branch and I see alot of working going on for R2. I am currently waiting for sinovoip to update me about the R2 shipment, I will start testing something with your kernel once I receive it and then I will have more questions.

Thanks

Hello Ray, I am about to get my R2. Is there any update on freebsd port? If you need me for any testing and working on it then feel free to contact me so I can help you with my time and skill, as much as I can.

One showstopper cleared, one left on the way :slight_smile:

Let me know, when you get your R2.

Hopefully tomorrow. I have some pkgbuild ready to build for it, giving manjaro a try myself as officially armhv7 is depreciated from manjaro but i will use the arch repo to build it.

What’s the status? Would you like to add me to your repo if you have it online?

Received my R2 but this doesn’t seem to power on. :frowning:

Firstly no power supply was sent so I used my 12v 1amp but it doesn’t turn on. When I press power button the leds gets turned on until I release the power button, I plugged a usb power screen to check if anything happens but it just turns on until I release the power. This means its not turning on at all.

I think it should power on as soon as I turn on the power of the power supply.

Video

I followed this link and it think i need to learn the power on method for this device too lol.

You need to press powerbutton on r2 nearly 10 seconds for power-on. R64 will poweron on power available

I tried but no luck. I tried most of the recommendations in the above link.

  • Holding power button for 10secs. No luck
  • Connect otg usb to pc when power on. Still i see led light on but nothing on hdmi. Idk if hdmi works or not in preinstalled rom.
  • Then i had to in sd card with your ubuntu rom and hold powerbutton for 10seconds then it loaded.

Now I can see linux but only the server edition. So I assume there is nothing in emmc as in both the way it is booting to the same os.

Conclusion is the device doesnt even power on without a sd card in its slot. Thats not so practical.

How can I make this device power on directly without the need to press and hold power button for 10 secs or atleast press once to power on?

Per default there is nothing on emmc,right…you have to flash something :slight_smile:

you can put 5v to usb-otg-port or solder pins of powerbutton

Hdmi only works with hdmi-driver in linux-kernel and a specific cmdline (fbdev)

What do you mean with “only server edition”? my ubuntu is a basic ubuntu without x-server to run a headless system,but you can install a graphical environment

Ah ok, But I read on a R2 listing that it comes with android lol.

I tried this but I didn’t know it will boot after 10secs always. Now it boots with 5v in otg-port.

Would this lead to device getting power down after around 20secs? like normal devices do ?

Yes HDMI is working fine now.

Yes I got this but I was confused of the size of your img. 7gb for headless img ? As my KDE with all extra app would come up to 5.5gb max. I am pulling a mate DE to try and see how smooth the device can work as a DE then I will start working on Manjaro.

Next I will wait for @ray to advice me how to start testing his freebsd built.

only a few r2 come with android…maybe only some from specific shop.

Solder pins affect poweron not poweroff. since you permanently bridge the switch you need to bridge it. But you have to disable a kernel-module/acpi or you get reboot-loop (pressed powerbutton cause powerdown after acpi is running)

The 7g is only partition size…you have much free space.

Yes thatsy I would use 5v on otg I guess.

Oh that’s why, I think that’s the reason we never use fixed img to build, instead we use the actual size and then a script on startup which resizes the partition before the first boot. But thanks your img worked smooth.

Next I am trying to flash 2017-09-04-ubuntu-16.04-mate-desktop-bpi-r2-sd-emmc-v1.2.0.img on sd. Should I just dd it to emmc after I boot into the DE?

The name suggests it also supports emmc. on forum-page for the image the steps should be described for emmc…

Normally you need to flash preloader to boot0 and (on the early devices) rewrite emmc partition config (via uboot or mmc-utils)

I had not time for creating a auto-resize-rootfs :slight_smile:

1 Like

Thanks for the advice. This sounds like some work which I don’t want to do now but later when I find a good working DE. Do you have any link for a full working DE for R2?

I think that will take sometime so instead I have started working on Manjaro port for R2, facing some problem with it as manjaro dont have native armv7 support anymore, so I have add it by using Arch rootfs.

I will be using your latest 4.14 and 4.19 from git release. Currently have to sort out the rootfs first then I will get back to you will more questions if I get stuck anywhere.

Really appreciate your support and quick responses.

All steps are described in my wiki.

https://www.fw-web.de/dokuwiki/doku.php?id=en:bpi-r2:storage#install_os_on_emmc

mmc-utils are compiled on my repo (4.14-main/utils)

You can install any on my image,but due to r2 limits in cpu and ram you should choose any lightweight e.g. lxde

sudo apt-get install xserver-xorg lxde xfonts-base

Thanks.
I think I will install de on sd card and make and img of it for future use. Also will try ur guide. Thanks.

Thanks I tried this and Now I have LXDE but I think it is not so usable with DE. The cursor takes long to move and good amount of CPU resource is used just to move the cursor.

So I assume we should only use it with cli. I was successfully able to build armv7h image of Manjaro Server edition with R2 specific package. So Today will try building a package with your 4.14 kernel as almost everything works on that release and your buster boot partition.

Will get back to you once I build specific img for R2. Thanks for your support and responses.

Hi Dear, Any update or anything that I can help you with, to test the freebsd on R2 ?

What was the Showstopper which is clear and which one is left? I am curious to test your build. I am still waiting for your response. Thanks.

Oh, sorry. Was busy, then forget to answer. I’m forget what it was, but you can check it with FreeBSD commits if you interesting ([email protected] it’s me) IIRC there was two:

  1. Extra check to not add same memory range twice
  2. Fix to elfcopy to allow boot with binary kernel (kernel.bin)

One left is big - automatic device reordering (by dependency) on attach.

Here it is https://reviews.freebsd.org/D21478 . It’s work, but will not be applied. We with Natan Whitehorn working on better one, as time permit.

give me your email, I will send you copy of MT7623 related sources I did.