BPI-R2 Ethernet Switch

BPI-R2 running Ubuntu image from http://www.banana-pi.org/r2-download.html . swconfig is not installed / cannot be found. I cannot seem to get the eth0 interfaces up and running. What am I missing?

I tried compiling swconfig via the link below. It worked. But swconfig list shows nothing.

Kernel 4.4.70 does not have switch-driver (mt7530)included. Driver is working in 4.14,but there are issues with sdcard and maybe gpio

I’m interested in this feature too, but mainly for VLAN functionality. I’ve at least seen my board detect the second ethernet device with the latest master from github (4.4.70), although I don’t think I ever tried to enable it.

Maybe it’s feasible to backport the driver, I can take a look when I have time. Perhaps someone else already tried to do it? Would be great to see this from BPI of course :yum:

Its not super urgent, but when do you think the drivers will be integrated? If longer than a month or two what is my best work around?

I’m also interested in that…i’ve been asked here Switch support separate vlans? but it seems nobody is working on it. it looks like 4.14+ needs some time to support the missing features (sdcard,gpio,onboard-wlan) so 4.4.17 ist the best choice atm.

Maybe this help for 7530: https://github.com/garywangcn/bpi-r2_lede/blob/700175baa1e26c58ccccf196b0af99b233d63422/target/linux/mediatek/patches-4.9/0030-net-next-dsa-add-dsa-support-for-Mediatek-MT7530-swi.patch

You can use 4.14 if you boot from emmc and don’t need onboard-wlan and gpio

eMMC is new to me. Where to get a compatible 4.14 image and how to install it onto the eMMC? I do not need wlan and gpio right now

i had not tested emmc yet. So my way will be using a emmc-compatible image (debian,ubuntu) booting from sdcard and installing it like described in the manual from image


Note that you must shrink that image,because it is larger than 8g and won’t fit emmc, see BPI-R2 new Image:Ubuntu-16.04-mate-desktop-bpi-r2-sd-emmc-v1.2.0.img.zip 2017-09-04

How about installing onto a USB drive or SATA drive? Would that work?

Uboot must be loaded first (from emmc or sd-card,but don’t have sata driver included yet. You can load kernel from sd/emmc and then rootfs from sata/usb.

May be best to just get an BPI-R1 while we wait :slight_smile:

I’m glad I still have the R1. about to order the R2 and start working on it so I can swap when the R1 dies on me.