[BPI-R2] Debian Bullseye image

Hi,

i created a basic debian bullseye image with kernel 5.10.64 and systemd network config.

https://drive.google.com/drive/folders/1oP7jy1KrrIOifvImo2nQ59wx3_9hHkgk?usp=sharing

  • bpi-r2-bullseye_incomplete.img.gz
  • bpi-r2-bullseye_incomplete.img.gz.md5

wan is set to dhcp and lanports are bridged with IPv4 192.168.1.1

tools, firmware and wifi.sh for internal wifi are included (wifi.sh to startup, BSSID: R2_AP0,192.168.10.0/24 dhcp-server enabled)

ssh server is ready and with PermitRootLogin enabled (please disable for productive use)

u-boot 2021-07

user: root PW: bananapi

debug-uart-cable is recommended :slight_smile:

rc.local enabled, pppoe-service prepared (not enabled)

2 Likes

found 2 misconfigurations (will fix in next version):

Zusammenfassung
  • lanports are not assigned to bridge:

create a /etc/systemd/network/lanbr-bind.network with the folowing content:

[Match] Name=lan0 lan1 lan2 lan3

[Network]
B[Match]
Name=lan0 lan1 lan2 lan3

[Network]
Bridge=lanbr0ridge=lanbr0
  • DHCP-Server wrong configured (used config from my main router without bridge)

/etc/dnsmasq.d/interfaces.conf (disable all other options except for ap0 and add the following)

interface=lanbr0
no-dhcp-interface=eth0
dhcp-range=lanbr0,192.168.1.100,192.168.1.150,255.255.255.0,48h
dhcp-option=lanbr0,3,192.168.1.1

uploaded new version with fixed config.

added also a part from my nft ruleset to enable masquerading and some basic rules. apply with (maybe change path, as i have it in /usr/local/bin because of nft-script i have not added here):

nft -f /usr/local/sbin/ruleset.nft