BPI-R2 boot / power suppy

OK people, here are my experiences that you might find useful :slight_smile:

Obviously, first of all make sure you’ve got the second preview release correctly written to an SD card and inserted into the board.

I contacted support, you need to hold down the power button for ten seconds for it to boot. For whatever reason, if you just press it, or hold it for any shorter length of time, it just turns off.

The running status of the LEDS is bright green at the front with a dim red next to it and at the back of the board next to the HDMI socket, a red LED.

There’s a group of components on the back of the board that are positioned in such a way that while holding the board to plug in the power, or to pick it up perhaps - it shorts some contacts - this leaves the board in a kind of ‘crashed’ state - if you unplug the power, wait a moment, and plug it back in, being careful not to touch the board - it’ll be in a normal bootable state.

hold down the power button for ten seconds etc

the screen goes white - then will either go to a linux post, or you’ll get no HDMI signal - if you press the reset buton, the RGB lights on the front light up just like when you press the power button, the board resets and it consistently works correctly if it didn’t before.

I’ve been very methodical, so if your experiences differ let me know so we can establish the normal operation of this board so any problems become apparent.

For example, after booting, there doesn’t appear to be a registered audio device for the HDMI audio output for me - perhaps this is a pending driver that wasn’t mentioned that’s currently not working.

Either that or there’s a potentially problem with my board or cables.

Also, whenever I shutdown the board, the lights just stay on - pressing the power button after it’s on, or holding it down for any length of time - does nothing - you have to unplug the power and plug it back in to get back to the ‘lights off’ state. The reset works fine - so perhaps the power button requires something additional to function correctly - but there doesn’t currently appear to be any non-software way to return the board into the ‘lights off’ state for me.

oh and the board doesn’t remain on at all without an SD card inserted - no matter how long you hold the power button, the lights go out. I’ve not yet setup the board to use eMMC - the instructions say to remove the SD card - perhaps it’ll remain on without an SD card in that configuration.

just share my experience… if usb otg port is connected to pc, you dont need to hold down the power key and can short the boot time.:grinning:

The system won’t boot up in my case. Neither when pressing boot for 10 seconds nor when connecting usb otg. The HDMI signal gets lost.

I followed the eMMC instructions exactly from the “preview 2” post, but the board wouldn’t boot after the image had been written. The lights go off no matter how long I hold down the power button. I inserted the SD card again and the board booted - but it booted and mounted root from the SD card.

I can access the eMMC perfectly fine - create partitions etc but can’t boot from it.

Unable to get HDMI audio to work, tried everything - if anybody does, please let us know so people can identify what’s faulty and what’s waiting for driver support.

Successfully compiled the BPI-R2 kernel from a GIT clone on the device itself :slight_smile:

All four cores were maxed out (-j4) for quite some time - SoC would of probably been uncomfortably warm without a heat-sink - if you’re going to drive it that hard for that long - then I’d definitely recommend a heat-sink just to be safe.

I cannot find out the preconditions for successful booting. Sometimes it boots now sometimes not.

But I can confirm Johnnys experience about flashing on eMMC. Without SD card nothing happens and with SD card it boots from the SD card only.

I can confirm that sound support isn’t compiled into the kernel - I configured and built the R2 kernel with support for some mediatek SoC sound drivers I saw listed and updated my SD card. Sound is now working fine through the HDMI port :slight_smile:

They might of not compiled it in for a good reason that I don’t yet know about - but so far so good :slight_smile:

Watching youtube videos in a window is smooth, sound works fine - full screen is slow (around 10fps with quality of 480p on youtube) - I guess we’re still waiting for hardware decoding support etc

PCIe is working fine - have a broadcom WIFI adapter setup (had to add cfg80211 to the kernel as a requirement of the broadcom module) - I’ve also got a mini PCIe to full sized PCIe converter which I tested - it identified an Nvidia graphics card and the Nvidia ARM drivers worked great - similar performance (in my engine) when the mini PCIe extender was used on an Intel laptop - the two available PCIe ports might make this cheap board an attractive coin mining solution.

Still had no issues with sound, all working fine - there’s a specific option for the MT7623N - it appear to share a driver for another MTK chip which gets enabled upon selection.

Both network adapters are fully functional - created a bridge between the two and then transferred 10gb of data between two GB LAN capable machines with the R2 in the middle - performance was the same as if I’d connected them directly.

Not tested SATA performance yet - I read there might be issues on this SATA chip with two drives simultaneously but it appears that it was fixed long ago and the fixes seem to match the source that’s currently being used - so probably nothing to worry about if you’re using both.

Played around with some basic GPIO - worked fine - not tested I2C/SPI yet.

So far so good! everything is stable and running great - will be handy to have the internal WIFI/BT working (the MT6625L 4 in 1 chip also supports FM + GPS but since there’s a single antenna connector and the datasheet shows the WIFI antenna pin as being different from the GPS + FM pins - I’m assuming this functionality wasn’t intended to be used and will simply not be part of the drivers)

the sound source you tested is with HDMI ? and specific option you mentioned here is for I2S? the SoC having I2C/I2S , so i assume they should work for some codec board.

the 6625 the version bpi r2 used doesn’t include FM and GPS . and BT/WIFI is probably sharing single antenna

Audio over HDMI - I don’t currently have the capability to test the I2S bitstream (if it’s currently working) - I lack sufficient hardware to test all the pin-out features listed (UART, I2C, SPI, PWM, I2S) - for the time being, full reports on that functionality will have to be from somebody better equipped.

Ah I see - so just WIFI and BT on this version if the 6625 - thanks for the info!

Yes - there’s a single antenna connector and the 6625 datasheet states that BT effectively shares the 2.5G antenna (there’s a diplexer splitting the single antenna between the 2.5G and 5G pins )

It’s useful to have the bluetooth but I can’t imagine the 1T1R WIFI setup is going to be earth shattering - if I employ one of these boards for heavy WIFI use? I’ll probably drop in a decent ac capable mPCIe card.

I believe the board has the MT7530B switch - there’s port/vlan specific functionality according to the driver in the kernel (or at least when I just googled) - I’ve not tested that - if anybody does then please post your results for the people intending to use the board as a router/firewall/whatever.

I’ve also not tested the battery capability - I need to identify the connector used - standard 3.7v lithium so I assume there’s a step-up converter on the board - it’s unclear what the battery will power and how many amps it’ll draw. (just the SoC/emmc/card reader? SATA power too? what about two drives?)

I note that the second SATA power connector is a four pin - I’ve not got my meter on it yet but I imagine it’s providing the 12v and 5v lines or they’d of just provided a 2 pin like the first connector. So that implies it was intended to power a 3 inch drive for example - two drives, one of them being a 3 inch? well - that’s a lot of power to pull across the board - I’ll test that when I’ve got one to spare :wink:

I imagine there are people with far more relevant experience to do testing - just trying to put some information out there so other people know what to expect at this stage.

I get the exact same problem. It seems to start, I get HDMI signal and a grey screen then I loose HDMI signal. Pressing the reset button and same thing, get signal for around 10 seconds then blank no matter how many times I reset. Using the latest image dated 2017-08-1

I’ve now tried 3 different images and exactly the same for each one. Preview 2, Preview 3 plus the nodered image. Installing a Ubuntu vm to try making my own build but fast coming to the conclusion that I’m not going to get anywhere.

Ok managed to get it to boot by compiling and deploying from git. Now though the Monitor comes up with an INVALID FORMAT error but I can SSH into the unit.

Hi, you can test wolfson codec which has been supported on mainline.


you should tell sinovoip to add so much good thing what you did for the hardware into the r2 board. Otherwise, it appears to waste your effort sadly and bury such kind of function in the blank.

Thought I might be able to use it without the HDMI but now it just floods the network taking every device offline including my PC. Then it goes into a reboot loop.

Well after several attempts at reburning images I now have it working without xorg but there seems to be a problem with the kernel features. iptables always comes up with the below error

[email protected]:/home/pi# iptables --list

modprobe: ERROR: ../libkmod/libkmod-module.c:192 kmod_module_parse_depline() ctx=0x7f5ec008 path=/lib/modules/4.4.70-BPI-R2-Kernel/kernel/net/netfilter/x_tables.ko error=No such file or directory
modprobe: ERROR: ../libkmod/libkmod-module.c:192 kmod_module_parse_depline() ctx=0x7f5ec008 path=/lib/modules/4.4.70-BPI-R2-Kernel/kernel/net/netfilter/x_tables.ko error=No such file or directory
modprobe: ERROR: could not insert 'ip_tables': Unknown symbol in module, or unknown parameter (see dmesg)
iptables v1.6.0: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

I don’t see this problem, Can you please try the latest firmware? (get it from this link http://www.banana-pi.org/r2-download.html)

I have been doing all my testing from preview2, preview3 (https://drive.google.com/drive/folders/0B_YnvHgh2rwjbUNpZXIzMnlKSGM) and a manual build from git. I will go back to preview2 once more and try again but fairly certain.

Hi all, I have just received a BPI-R2 V1.1 And When I try to boot with SDCard, during 4seconds I have a green screen and after I lost the display. No activity on LAN and WLAN port. A red led is ON near the HDMI port Leds green and blue is ON

I have tried with img:

  • ubuntu-16.04-mate-desktop-docker-preview2-bpi-r2-sd-emmc.img-2017-08-01
  • Raspbian :2017-03-10-raspbian-jessie-preview-bpi-r2-sd-emmc.img