BPI-M64 new image:Armbian OS aarch64 for BPI-M64 | Download

BPI-M64 new image:Armbian OS aarch64 for BPI-M64 | Download

download link:


thank you geektillithertz.com share it.

Discussion over at armbian forum if someone wants to catch up


1 Like

This is a good image. By the way, is not the image of Ubuntu Xenial available?

You can try Ubuntu_xenial_desktop_nightly.7z from https://img.armbian.com/pine64/

But if I understand the linked discussion above correctly these are Pine64 images and do not fully support the BPi M64?

1 Like

Hmm, is that the image of Pine 64 can be diverted as it is? I will hurry to try it.

exactly the same image would work, no change needed to be done

I introduced nightly and tried it, but apparently it does not work well.

Hi folks, the thing boots up on my m64 but no WiFi. I am also experience high packet loss on eth0 in my GigE network, specifically when I ping an RPI through a Netgear consumer grade switch and a Linksys router, ping complains of high packet loss. None of my other systems have this problem. Is this working for one of you?


Ok never mind, I read about the GbE problems most are having. Will go with Avafinger’s stuff next.

I kind of expect Bpi will not do as well on the software side. But I never imagined it would be this bad honestly.


You should have checked this forum before. The mess is well documented :wink:

this image is share by user .

you can test this image ,it support gMAC

Dear Sinovoip Bpi Team,

I really appreciate your attempt to help. I used dd on OSX with bs=4m. It boots and I see the 4 penguins, and then the screen goes dark. I see the ethernet port LEDs blinking so it is alive but I have no display. Can you please help?

I did not find this image previously in the M64 “manual” page for Linux at https://bananapi.gitbooks.io/bpi-m64/content/en/linuximageforbpi-m64.html

As you might know from my other posts, the 2017-Feb Ubuntu image doesn’t work for me. I get a few meteor like white horizontal lines for a split second and the system restarts every 11 seconds.

The 2016-June-19 image a bit further down on the manual page is 3.9GB and somehow I cannot download it even after 6 tries. I don’t understand why, I have a gig-e Internet connection that is pretty good and the destination is Google. I have never had problems downloading anything so I think something is wrong on the Google end and you might want to repost it if it is a working image. I suspect there are others who can’t download it either. Please give it a try as it is driving us crazy.

This image you have just linked is newer and from 2016-June-21 and cannot be found on the M64 “manual” page for Linux, you might want to add it. I also see it is 2.1GB and I successfully downloaded it on my first try.

Brgds, Song

Hi, ok it does boot up to Ubuntu Mate, I just hit the reset hard button and the thing surprisingly booted up! Trying to sort out networking now, thanks. I think you should link this to the manual, and sort out the 3.9GB download in the manual. My 2 cents.


Sigh, I got happy too quickly

  • the GUI crashes every few minutes if Im doing stuff, the system pauses then throws me into the login pane. Im hoping I dont have this problem when I run it headless with the GUI but Im not sure until I test more.
  • no WiFi in this build, I need it as well as GbE
  • the GbE support is not sufficient. Can ping itself, massive packet loss like 90+% when I ping the router or other devices on LAN. Packet loss problem goes away if I slow it to 100 mbps which is a no go. I bought this SBC specifically for GbE: ethtool -s eth0 speed 100 duplex full

Guys, is there a single Linux image that works with GbE, WiFi and is stable. I also need up to date security but let’s skip that for now.