BPI-M5 not loading - help!?

Tried both Linux (micro SD) and Android via cable on eMMc. The result is the same. The blue LED flashes. Not loaded. I tried all the images.

Here is a video for understanding:

Help solve this problem.?

We have some boards freezing during startup and the problem was the power supply.

Try with a bigger and better power. If you can, get a 5.1V one.

Also I dont recomend the micro USB power connector. I had many problem with it. Use the 5V pins on the connector or better to put cables direct to the pads.

I used two power supply - but through USB Type-C. I’ll try to power through gpio …

If you can use the two 5V pins and two GND pins.

I connected like this - it did not help. It remains to take a more powerful power supply …


Did you test with a new image? Which image are you using?


Via USB_Burning_Tool

Here is the data we managed to get through the serial port. Log.txt (104.5 КБ)

From your second video, the M5 should have booted, but no HDMI output? Yeah? In the data output from the serial port, does it finally enter the shell state?

Connected to the monitor via HDMI - there is no image at all. Tried different power supplies. And fed through the GPIO. Tried many looks. The result is the same - The blue LED flashes constantly.

Can you show more details of the debug output from the serial port with a video or picture? If the system is successfully booted, and there is no HDMI output. Consider the HDMI cable, the monitor does not fit and there is a problem with the M5 HDMI hardware interface

If you have tried more systems, you need to pay attention to these problems. image OR image

Erased (Full Erase) eMMC - by pulling out the cable by 7% during formatting. After I recorded the image on the MicroSD. The result is the same. Here’s a video booting up Android 9 with eMMC - don’t you think - which booted very quickly judging by the LEDs. And at the end, the blue LED always flashes. The board should boot regardless of the HDMI cable.


Booting Linux from microSD

Start Linux Debian SD.txt (92.9 КБ)

It booted OK? You have video out? Can you login via serial?

No video. I use an adapter (pictured). The adapter works with other devices and set-top boxes. So far, I have only been able to listen to the serial port.


Can you provide information like the picture below? Is there a stuck somewhere and a login or something. From the log file you provided, I think it has started successfully. It is most likely a problem with the HDMI port or cable.

also Can you login via serial?


Through serial port it seems it was possible to be connected. It asks for a username and password. login: alarm/alarm, or root/root is not appropriate. It turns out the reason is in the cable?!



  • bananapi/bananapi
  • root/bananapi
  • root/pi

if not the HDMI port issue , you may try to use hdmi to hdmi cable.

Problem - solved. The legs on the HDMI port were badly soldered. Took it to the workshop - soldered (warmed up) and it all worked. Thanks to all.


I’ll post your questions to our forum. Maybe someone will have the same problem.

1 Like