BPI-M3 new image:ubuntu-mate-16.04 2016-04-22


  1. BPI-M3 kernel 3.4
  2. username & password: pi/bananapi , root/bananapi
  3. support HDMI 1080P & 720P
  4. support GMAC
  5. support WIFI
  6. support bpi-bootsel cmd can switch to (bpi-m3 & bpi-m2 & bpi-m2p)
  7. support uEnv.txt to fatload script.bin & uImage
  8. support uEnv.txt to set video 1080P & 720P & 480P …
  9. support vdpau
  10. support video play 1080p with mpv & vdpau

Google Drive:

MD5: 9e3e3695cfb84aa2552d8c20ab9c6134

how to install on emmc??

not working gpu,chrome crash. Scripts for resize sd card and cpu temp monitoring,run as sudo. https://mega.nz/#!oEsQHRIT!CSuBHVaOg4v0pX0jmeMlBaPhfInuc0R-_oC3VxQEqSc

common crash on network-manager-gnome in executablepatch /usr/bin/nm-applet

play hd videos with low cpu usage finaly :slight_smile:

uninstall chromium sudo apt-get purge chromium-browser

download my package and run sudo dpkg -i *.deb https://mega.nz/#!BUkyXA7C!XNJC6t2zReINHI6OmeFgOcGwH2DuF94u5xehNCj292M

1 Like

we want to let this image on BPI-M2,BPI-M2+, BPI-M3 with bootsel. so GPU not working .

more about VDPAU


Whats the pi users’ password / root password / sudo password?

pi/bananapi , root/bananapi

please reference this link:


thats bad,any update to get gpu on it?

we will try do a version for BPI-M3, let GPU and 1080P all working. :slight_smile:


yeah,that will be cool for real

yes ,we have test it success , and BT driver have working ,but BT driver code have some issue need to fixed . when we ready ,will update a version for BPI-M3

Hello, i flashed this image, and i have two questions:

  • how can i change the screen resoltuion to 1920*1080?

  • i use a 16 GB SD card, but an error comes there is only 300 MB free space, how can i solved it? (What do you recommend to delete, i am new in Linux’s world)

Thanks the answers

Hi to all, I’m a new owner of a bpi-m3. Is there any good news from video drivers side? I installed last 16.04 ubuntu mate image, then followed these instructions for update my system, then rebooted but still no pvr drivers etc…

What am I doing wrong?