BPI-M2 Pro - Need help re: Installing

Hey there, first time using a Banana Pi board- and it’s incredibly frustrating.

So here’s what I understand so far:

  1. There is emmc that you can flash your OS to. It comes absolutely blank (correct me if I’m wrong here).

  2. The guides that are on the wiki group both the M2 pro and the M5 together. M2 Pro has no usb-c leaving the guides completely useless.

  3. I’ve tried using the usb mini port, with no luck re: flashing the Android 9 system

  4. I’ve tried flashing coreelec and emuelec to a microsd. Using the banana pi m2 pro dtb. Nothing.

So right now. I have a useless little box. No HDMI output on TV or monitor. Some lights turn on, but no-one is home.

If anyone here can shed a little light - I’d love to see at least… An image on my TV / monitor.

Right now it might be worth going ape with an angry review with this little box.

Thanks, y’all


  1. emmc is empty, so you can flash the image you want.
  2. M2Pro has no typec, but micro-usb onboard for usb communication, so why the wiki guide useless?
  3. read the android install guide step by step carefully, and confirm usb device detected correctly by your PC before doing this, BPI-M5 with Android system
  4. read and unstand the Coreelec install guide before using it,

Thanks for clearing a few things up. I assumed that microusb had to be used, but using a good cable is also crucial (my issue)- without this it wasn’t detected in any of my computers.

Thankyou again for the reply. Android 9 is now on the emmc.

Have you had coreelec running on your system with no issues?

Ta Tim

yeah, I tested the coreelec image a few moths ago and it works well with android on emmc for dual system. the key point is m2pro board has no update key, so after bootup to android first time, you must install reboot_to_LibreELEC.apk to reboot to CoreELEC on sdcard. You can also google another version of this apk and install it.

After bootup CoreELEC you can click “Reboot to eMMC” in power menu to reboot emmc android, without that you still get CoreELEC boot next time.

Thanks for the response.

The issue was really with the M2 Pro coming with absolutely no documentation, and then I had to go off on a wild goose chase to get any sort of information - and then finding a solution for another device- with totally different ports. If it was confusing for myself, I can’t imagine how bad it’d be for the average layman who came off the street buying one.

Managed to get Android 9 on it and some other goodies.

Thanks again.