BPI-F3 does not boot from SD

Hi All,

I (finally) received a new BPI-F3 and I followed the steps for installing the biandu SO as it is explained in Getting Started BPI-F3 | BananaPi Docs. I flasehd a 32GB card with the balenaetcher application and inserted into the device. However, it does not show anything in the screen. I have with the traditional power supply and with an USB-C but nothing. Is it possible that the device is in DFU mode? In that case, how I can exit the DFU mode?

Thanks in advance

BTW, the green light does not blink.

What voltage is your power supply? Needs 12V not 5V. I too have just received a BPI-F3 and had no trouble.

I have tried 3 different power suppliers, including the regular one and a USB-C

How old is your SD card? I realized they don’t last forever.


The newest 256GB was 3 days old :slight_smile:

What are you burning it with? Do you have access to linux and do a DD of the image to it ?

The command would be

do an lsblk to see which device it is.

sudo dd if=imagename of=/dev/yourdevice status=progress


I did it using the Balena etcher app on my Mac. I will try with a Linux system. Thank you so much for your help. I will keep you posted!

I used Balena Etcher on a Windows PC. Worked fine although you need to resize the partition created after booting as you receive an error message about low space on the SD card. I also installed an nvme and that works well. The green LED on mine pulses like a heartbeat.

Have you tried the reset they say on their site? Try the 2 options, unplug the power, keep the first button closest to power down and plug the power in. The 2nd is hold down the 1st and 3rd and do the same power cycle.

Which image are you burning to SD card by the way? Franco

Thank you so much. Today, I try another board (my friend received it this morning ) with my setup and it worked at once. So there is something wrong in my board. I tried booting my friend’s one without SD and the the green light didn’t blink. Therefore I suspect that maybe the SD reader does not work correctly. I have asked for the refund and bought another one. I will update you once I receive it :slight_smile:

Thanks again

Did you try the reset buttons? The two options might help reset the board. I know I had to do it sometimes.


I am having the same problem. I don’t understand what you mean by doing the reset. I don’t have a 12V usb-c connection but I do have the 12V barrel jack connection.

I have tried Bianbu image, armbian image using an SD card, neither works.

thanks Bob

It says on the their main page if you have an issue, use the buttons located close to the SD card slot. Unplug the board, hold down the one closest to the USB-C and plug it in when holding down that button. The second is holding down the 1st and 3rd button and doing the same steps.

This resets the board.