BPI-CM4 CPU frequencies not working

In /boot/env.txt, there are two settings: max_freq_a53 and max_freq_a73. These are marked with a default value in the comment, but the values in the file do not match.

More importantly, no matter what value I set here, the CPUs are both limited to 1704.

For example, I tried setting them both to 1800, yet:

% cat /sys/devices/system/cpu/cpu[02]/cpufreq/cpuinfo_max_freq



% cat /sys/devices/system/cpu/cpu[02]/cpufreq/scaling_available_frequencies

500000 667000 1000000 1200000 1398000 1512000 1608000 1704000

500000 667000 1000000 1200000 1398000 1512000 1608000 1704000

In other words, both the A53 and A72 cores are limited to 1.704GHz, even though I set 1.800GHz for both. 

You can see the setting in the file took effect by looking at /proc/cmdline:

% cat /proc/cmdline

root=/dev/mmcblk0p2 rootfstype=ext4 rw console=tty1 console=ttyS0,115200n8 board=bananapi_cm4 loglevel=7 fsck.mode=force fsck.repair=yes logo=osd0,loaded,0x3d800000,panel vout=panel,enable hdmimode=1080p60hz   fbcon=rotate:0 net.ifnames=0 wol_enable= max_freq_a53=1800 max_freq_a73=1800 serial=290b1000011e04000006373837504350 systemd.machine_id=290b1000011e04000006373837504350 jtag=disable coherent_pool=2M pci=pcie_bus_safe

How do I set the CPU frequencies to the other values? Thanks!

As you can see, cpuinfo_max_freq value is 1704, so you can’t set more than 1704, amlogic vendor code limit to this value.