BananaPi R64 - Ubuntu 18.04 System very slow performance

We have used the vendor provided image taken from the link in the wiki page

We are running the system from the SD card since we were not able to find any support for EMMC. We observe the entire system to be responding extremely slow to any Linux CLI commands. To provide and example we have provided the screenshot of the CPU utilization and time taken in running the netplan utility in raspberry pi 4 and banana pi r64. We have used the /usr/bin/time command for profiling the time and memory requirements for netplan utility.

Please let us know is more information is required to debug this issue. The above provided images are only representing an example and the slow performance is prevelant across the system.

Which kernel do you use? There was a problem with all kernels and newer uboot (imho not the 2014). I recently added patch to reset mmc-controller which solves slow performance

You find some information about emmc in my wiki. There is also a new bootchain.i had created simple sdcard image (debian buster),but this needs some modifications for emmc (replacing boot-headers (first block and bl2 in boot0)

Hi Frank,

The above posted images are with kernel 5.4. Based on your information provided in this article

we downloaded r64_buster_newatf_5.10.img.gz and flashed it on our SD card. The system performance seems fine and we are not facing any lags. But when we tried to profile the netplan apply command, the CPU utilization reaches ~92%.

We are still validating our required Linux CLI commands and observing whether we are facing any lags.

you use ubuntu with custom 5.4 (or do you use my 5.4-main)? my image is debian buster…the bootchain should not affect netplan because netplan operates in linux not ATF/uboot.

make sure you have the sdcard-reset-patch applied in your kernel…

Are you cooling the CPU? Check CPU temperature and if the CPU speed is throttled.

Temperature: cat /sys/class/thermal/thermal_zone0/temp

Speed: cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq


Debian has no netplan activated. I guess you need to disable the ifupdown before…else these 2 may block each other…

If you use my image (basicly revert my changes to deactivate netplan):

  • remove “netcfg/do_not_use_netplan=true” from bootopts in uEnv.txt
  • uninstall ifupdown package