BananaPi BPI-M2Z(H2+) New Image Raspbian & Ubuntu Release 2018-07-09

Hi,

Could you please make a build with Raspbian Stretch Lite? Also, what can I do to get the ethernet port to show when I run ifconfig?

Thank you.

Hello, I am preparing to release some other images in few days;

did you mean “ifconfig” in terminal?

I think you could use root user to execute ifconfig in terminal.

I don’t see the eth0 interface when I run ifconfig in terminal, only wlan0.

which board do you use?

could please you do “ifconfig” , “bpi-hw” and show me the log?

[email protected]:/home/pi# ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:136 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11472 (11.2 KiB)  TX bytes:11472 (11.2 KiB)

wlan0     Link encap:Ethernet  HWaddr ...  
          inet6 addr: .../64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:108 errors:0 dropped:1 overruns:0 frame:0
          TX packets:123 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9079 (8.8 KiB)  TX bytes:16528 (16.1 KiB)

[email protected]:/home/pi# bpi-hw
bpi-m2z

Hello,BPI-ZERO doesn’t have RJ45 interface,it only has one wireless soc on board, you could connect Internet by WiFi

I will try the solution described here: http://forum.banana-pi.org/t/getting-ethernet-working-with-banana-pi-m2-zero/6137/4. Thank you anyway for supporting this board.

Hello, Thanks for this OS, i use raspbian on my banana pi zero M2 (H2+) and it works great. Except for the wifi that i had to set up manualy with this : http://wiki.banana-pi.org/Getting_Started_with_M2_Zero#WiFi_Client

MY QUESTION is about creating an hostpot with it. I use Raspap (wget -q https://git.io/voEUQ -O /tmp/raspap && bash /tmp/raspap).

All the installation works great, the configuration web page at 10.3.141.1 also works but no WIFI is available using my surrounding devices… Any idea? :frowning:

Hello, Did you connect Antenna?

and does sta mode work well on your board?

try “killall wpa_supplicant”.

then do “wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf”

i do have en external antenna. I can surf on the internet well. what is sta, how do i check that?

Kill supplicant didnt work

I have some trouble getting bluetooth to work with the raspbian image:

Job for bluetooth.service failed because the control process exited with error code.
See "systemctl status bluetooth.service" and "journalctl -xe" for details.
invoke-rc.d: initscript bluetooth, action "restart" failed.
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2018-11-05 23:43:59 NZDT; 529ms ago
     Docs: man:bluetoothd(8)
  Process: 1694 ExecStart=/usr/lib/bluetooth/bluetoothd (code=exited, status=226/NAMESPACE)
 Main PID: 1694 (code=exited, status=226/NAMESPACE)

Nov 05 23:43:58 bpi-iot-ros-ai systemd[1]: Starting Bluetooth service...
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Main process exited, code=exited, status=226/NAMESPACE
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: Failed to start Bluetooth service.
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Unit entered failed state.
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Failed with result 'exit-code'.

Wifi is working fine.

Hi, Jack! Ubuntu Mate is good! But is good for something more powerful than Zero, with more RAM and… more stable HDMI and more advanced GPU. For this kind of device I need an image of Ubuntu 16.04 but without desktop. So my question - is there such image? I’m developing a PCB for a robot based on ROS. My PCB is designed for use with Raspberry Pi Zero, but I was disappointed with its weakness. And I bought Bpi Zero, because it have the same size, same GPIO pinout and can run Ubuntu, for which I wrote all my software. But Mate is too heavy, I need a clean image without desktop.

Hello, I will provide a ubuntu server 16.04 to you

https://drive.google.com/open?id=1yTAJhTdiBlw6pEjoJz_-MOby723xH1VF

Hi, Jack, I am a newbie for BPI-M2Z, and just had bought a OV5640 Camera module recently. But it seems not working well. My problem is at … 1. How to disable the auto-exposure 2. How to disable and enable the auto-focus function. and so many functions from V4L is not working on OV5640…

Thanks and best regards.

Elliot

is possible to run kodi 18 with hw deconding on any build?

ther is no build for banan pi zero because only have 512mb of ram! i try ti build my one but no luck!