Banana Pi R2 Slow Speedtest

I installed snapshot-openwrt on the device nand chip without any problem. but there is a strange situation. I am reaching a maximum speed of 10mbps on the, etc. My internet speed is 100mbps. There seems to be a problem with ethernet but I don’t know what to do. I am using dsl modem in bridge mode. I’ve tried dhcp and pppoe modes, there was no change. I wonder if you have a problem with openwrt? is this a configuration problem? If not, is openwrt still not working properly?

Was it better before? Which kernel,which settings…

At least we still have no hardware-nat support so i guess the cpu is the bottleneck by calculating nat/pat or routing between ppp and clients.

What does your dsl-modem in bridging-mode? I guess you make pppoe dialin on r2,right?

My internet-connection is defined as 25/5mbit. Using german test provider

I get 23mbit/s down and 5.1 is 5 o clock pm now, i use my smartphone for testing on ap0, routing between ap0 and ppp device (on wan-port and vlan) and using debian 10 with kernel 5.4

It was never stable with openwrt before. Nowadays it looks good, at least on the surface, but there is the problem I mentioned. When downloading with idm, it downloads 100mbps at full speed. but there is an obvious slowness in opening the sites. I use it on zyxel nbg6716 device with openwrt installed without any problem. Something went wrong for banana pi r2. I’ve been keeping the device on hold without using it since the day I bought it. I guess there are no developers interested in Openwrt.

How do you download (to r2 or to client)? If only first access is affected,it sounds like an dns/caching issue (caching on r2 on slow storage)

switch tab is missing? I need to set vlan for pppoe. Have a problem with the mt7530 switch?

Afaik openwrt switch is for swconfig compatible devices…

You can define vlan directly on interface (e.g. wan)